YouTube wyświetla filmy w niebieskich kolorach

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!
Jest to poradnik nadesłany do nas przez jednego z Czytelników – Tripix – serdecznie dziękujemy!

Jeśli masz zaktualizowany do najnowszej wersji wtyczkę Flash (11.2.202.228) można zauważyć, że w filmach na YouTube jest niebieski odcień. To dotyczy tylko użytkowników, którzy używają NVIDIA’owską akcelerację sprzętową przez VDPAU. Używam najnowsze libvdpau 0.4.1. Chociaż istnieje wiele błędów, które popełniło Adobe, to nie martw się, ten problem zaraz się rozwiąże, a niebieskie ludziki nie będą Cię już prześladować – chociaż fajnie zobaczyć niebieskiego chińczyka…



Otwórz YouTube, by rozpocząć odtwarzanie pliku wideo. Kliknij w oknie odtwarzacza prawym przyciskiem myszy i wybierz Ustawienia. Tam w pierwszej zakładce odznacz „Enable Hardware Acceleration“.

Odśwież stronę i problem powinien być rozwiązany, nie! co ja mówię – musi być.

Jeśli nie jesteś w stanie nacisnąć przycisku, to otwórz inną przeglądarkę i spróbój ponownie. Mój przyjaciel nie mógł nacisnąć przycisku w Chrome pod Ubuntu, ale przycisnął go za pomocą Opery. 
Można również ręcznie edytować plik /etc/adobe/mms.cfg jako root

sudo gedit /etc/adobe/mms.cfg

i ustaw:

EnableLinuxHWVideoDecode=1 
OverrideGPUValidation=true

Oczywiście cały proces ma efekt uboczny, Twój procesor zostanie dodatkowo obciążony do dekodowania filmów flash. Niestety ta wersja wtyczki Flash jest ostatnią wersją, według Adobe, który będzie ostatnim Flash Player’em wydany dla systemu Linux. Nadchodzące wersje będą łączone z Google. Chrome wykorzystuje swoje API … Być może nadszedł czas aby dać HTML5 pole do popisu. Aby umożliwić odtwarzanie wideo HTML5 po prostu Dołącz do „HTML5 na YouTube. Oczywiście można również obniżyć swoją wtyczkę Flash Player do wersji poprzedniej – wybór należy do Was kochani.

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • emeritus

    Byłoby fajnie gdyby działało.Ściągnąłem kilka przeglądarek(oprócz Internet Explorera-hehe)i w żadnej nie da się odptaszkować tej opcji.Co ciekawe nie mam nawet tego pliku który mógłbym ręcznie edytować.Ciekawe jak będzie po zainstalowaniu 12.04?Na razie jak chcę już koniecznie obejrzeć jakiś filmik bez tego upiornego kolorku to ściągam go sobie na dysk i oglądam przy pomocy TOTEMA czy VLC.

    • Tripix

      Pomaga też przytzymanie prawego klika na filmioku, zjechanie na tę opcję i puść PPM.
      Często pomaga.

    • http://d29-139.pl niemiec

      U mnie na Chromium, Firefoxie i Operze nie da się nacisnąć. Pliku również nie mogę edytować (a raczej zapisać), bo takiego nie odnajduje.

    • michal121212

      A minitube ?

  • Tripix

    Ubije!
    a gdzie fotki!

    w mailu za kropkami *********

    dałem ci linki które masz wstawić za znaczkiniki [FOTO1,2,3] -.-

    [FOTO1] = ADRES
    -.-
    jak poprawisz możesz utylizować ten komentarz.

    • http://www.ubuntu-pomoc.org Szmitas

      Żadnych linków nie było, stąd poprosiłem o dosłanie – w drugim mailu też pusto.

      • Tripix

        Okej , dośle, prawdopodobnie,filtr poczty…

        • http://www.ubuntu-pomoc.org Szmitas

          Gotowe, dzięki.

  • Nose4s

    Niestety, w żadnej przeglądarce kliknąć się nie da, a folder /etc/adobe nie istnieje, może jakieś inne pomysły, downgrade flasha tez nie działa, występuje jakiś http error( przy próbie instalowania starszej wersji flashplugin-installer pobranej z lauchpada).. ta spędziłem nad tym bite 10h, chyba już wszystkiego próbowałem, szkoda że nie wszystkie pliki na YT są w HTML5…

  • Nose4s

    Oki solved…

    sudo mkdir /etc/adobe
    sudo gedit /etc/adobe/mms.cfg

    i wkleić tam te 2 poleconka.

    • sonixen

      Dzięki to pomogło w 100 %.

  • Ubuntownick

    Zmodyfikowałem plik jako root, ale przy okazji trochę pomęczyłem się próbując kliknąć ustawienia flash. Zauważyłem, że poszczególne opcje w paneliku można przeklkiwać przy pomocy TABa. Ale jak odkliknąc opcję nie wiem. Może ktoś wie.

    • http://www.ubuntu-pomoc.org Szmitas

      Może spacja?

      • Nose4s

        Hahaha, spacja pozwala na wszystko prócz odhaczenia opcji przyspieszania sprzętowego, przynajmniej na chrome, życie z nas kpi ;)

    • ja

      rozwiązanie problemu z niebieskim youtube jest banalne, wystarczy uruchomić film w pełno ekranowym oknie, można wtedy przklikać dowolne opcje, mysz i spacja działa wtedy bez problemu. Działa na chrome i ff

      • ubuntownick

        Bravo!

  • emeritus

    Dzisiaj instalowałem znajomemu Lubuntu na jego dysku ale na swoim komputerze.Dało się tę opcję bez problemu odptaszkować na Firefoxie.

    • Nose4s

      Gdzieś na jakimś anglojęzycznym forum czytałem że to ma jakieś powiązania z unity i zdaje się samo przejść na unity 2D rozwiązuje problem, niestety nie jestem w stanie podać linku a tym samym upewnić was i siebie, że mam rację.

      • emeritus

        To ma na pewno związek z UNITY.Przeczytawszy Twojego posta przelogowałem się na GNOME Shell-a,tam najspokojniej w świecie otwarłem Firefoxa i przy pomocy kliknięcia myszką odptaszkowałem sobie tę funkcję.Po powrocie na UNITY upiorny kolorek również nie występuje.

        • anula

          No jednak nie do końca. Ja w ogóle nie mam zainstalowanego Unity, korzystam tylko z Gnome Shella, a problem jest dokładnie ten sam – nie da się przejść nawet na zakładkę z odpowiednią opcją, a co dopiero ją odptaszkować…

          • http://www.ubuntu-pomoc.org Łukasz Schmidtke

            Dlatego jest jeszcze rozwiązanie oparte na edycji pliku, umieszczone na końcu. Zastosuj się do tego.

      • artek

        Tak przejście na unity 2D rozwiązuje Problem.Udało się:))))

  • RafciX

    A jak obniżyć wersję Flash`a?
    Wolałbym mieć akcelerację sprzętową (czy dobrze rozumiem, że wszystkie obliczenia co do skalowania filmu są wykonywane na GPU, a nie na procesorze, czy jest jakoś inaczej?), ponieważ mam pewne obawy, że filmy w HD będą sie zacinać.

    • Admc
      • RafciX

        Jeszcze jedno pytanie: jak wywalić tego najnowszego flash playera? Chodzi mi o to, jakie polecenie wykonać.

        • Admc

          sudo apt-get purge adobe-flashplugin

          • RafciX

            Niestety nie zadziałało, dalej filmy wyświetlaja się w niebieskich kolorach jak mam włączone przyśpieszenie sprzętowe. Przecież ten link to jest chyba do najnowszej wersji Flasha, przecież jest w nim człon 11.2.202.228, który oznacza najnowszą wersję Flasha.

  • prozak64

    wyłączenie przyśpieszenia sprzętowego pomogło.

  • pankamyk

    u mnie też wyłączenie przyspieszania sprzętowego pomogło!!

  • emeritus

    Wyłączenie przyspieszenia sprzętowego oczywiście pomaga,problem był właśnie z wyłączeniem tej opcji w środowisku UNITY.W moim przypadku po przelogowaniu się na GNOME-Shella wyłączyłem przyspieszanie sprzętowe klikając myszką.W UNITY w żadnej z ściągniętych przeglądarek mi się to nie udało.Ciekawe czy w 12.04 będzie podobnie?Ale teraz przynajmniej wiem co zrobić :-)

  • lawojku

    moim zdaniem odhaczenie wszędzie powinno działać, jeżeli nie działa – to po kliknięciu należy poczekać, nawet długo – kilka minut – aż załapie, ja przynajmniej w niektórych przeglądarkach tak miałem, po prostu długa reakcja, długi czas oczekiwania.

  • pankamyk

    poprostu trzeba dać [F5]

  • emeritus

    F5 ani zaden inny F u mnie nie zadziałał.Najeżdżałem tabulatorem klikałem kombinacje wszystkich F-ów również z Ctrl,Alt-em i oboma tymi klawiszami naraz.Dopiero po przelogowaniu na inne środowisko niż UNITY kliknąłem sobie to prostu myszką.

  • koko63

    U mnie po zastoswaniu sposobu 2giego zniknął ten trupi jad, ale flash się wysypuje :(

  • emeritus

    Co ciekawe dziś w YT znowu pojawił się upiorny błękit,okazało się że po chyba dwóch dniach akceleracja sprzętowa sama mi się włączyła.Znowu musiałem się przelogować na GNOME Shell i tam to odkliknąć a po przelogowaniu z powrotem na UNITY na razie chodzi normalnie.Ciekawe jak będzie w 12.04?

  • Tripix

    Dodam jeszcze że można usunąć flash-installer ( sudo apt-get remove –purge flash-installer)
    wchodzimy w Centrum Oprogramowania i wpisujemy Flash 10 i go instalujemy – włączamy akceleracje i gitara.

  • http://fihufil.rapidrage.eu.org/ Fih

    Można jeszcze problem rozwiązać inaczej a mianowicie:
    sudo mkdir /etc/adobe
    echo -e „EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true” | sudo tee /etc/adobe/mms.cfg > /dev/null
    I mamy normalny kolor i akceleracje sprzętową ;)
    Pozdro

    • babulon97

      To pomaga :)
      Jeśli komuś nie działała ta komenda
      sudo mkdir /etc/adobe
      to trzeba sie zalogować na root
      w konsoli „sudo su”
      i potem pokolei
      cd /
      cd /etc
      cd /adobe
      i wpisać jak powyżej
      Polecam rozwiązanie fih

  • lawojku

    rada powyższa rzeczywiście pomaga, tylko że koniec polecenia musiałem wykonać ręcznie, czyli zapis w pliku (dwie linijki), bo w konsoli nie chciało się to do końca dokonać – wisi proces i wisi…

    Przyspieszanie sprzętowe działa, kolory w filmach też, ale jest czasem tak, że nagle się przestawia „samo” na kolorki niebieskie i trzeba wszystko robić od nowa, no i znów działa.

  • babulon97

    Mi pomogło ogladnięcie filmu w innej przegladarce (opera) i po powrocie do chromium mam przyspieszenie i kolory :)

  • brudneflo

    witam mam problem ponieważ jak oglądam filmy na youtubie lub inne stronki to flash wysypuje się i nie wiem co mam zrobić żeby działał normalnie

    • http://www.ubuntu-pomoc.org Łukasz Schmidtke

      Jaka przeglądarka i Flash?

  • brudneflo

    mozilla firefox i schockwave flash 11.2 r202

  • Michas

    wszystkie sposoby u mnie nie działają;( a niebieski dalej

  • Aleksandra

    Miałam taki sam problem ale pod KDE. Używam Chrome. Weszłam w pierwszy lepszy filmik – oczywiście wszystko niebieskie. Weszłam w ustawienia, patrzę, a tę opcję mam zaznaczoną. Pomyślałam „A odznaczę, zobaczymy co się stanie”. Odświeżyłam stronę i bach! Wszystko pięknie działa :-) Nareszcie koniec z ufoludkami na każdym filmie.

  • multimen

    Tez nie moglem odptaszkowac w zadnej przegladarce i potwierdzam ze najprostszym sposobem jest edycja pliku z opisu tylko trzeba jako root utworzyc katalog w ktorym bedzie zapisany ten plik z poleceniami inaczej sie nie da i u mnie dziala filmiki sa w normalnych kolorach nareszczie :)))))))))))))))))) ufffff

  • raawek

    Kopiuję tekst – cytat z innego tematu, aczkolwiek podobnego i poradę, która to na bank naprawia;

    Najpierw instalujemy adobe-flashplugin oraz adobe-flash-properties-gtk albo kde, zależy kto czego używa.

    Jeżeli ktoś woli to zrobić graficznie, nie w terminalu, to w skrócie przedstawię szkic ruchów, będzie niektórym łatwiej.
    Najpierw ścigamy paczkę z flashami (nr. 10) dla różnych dystrybucji najlepiej moim zdaniem stąd:

    http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_10.3.183.18_archive.zip

    Następnie go rozpakowujemy, wybieramy wersję dla linuksa i rozpakowujemy dalej, zapisujemy gdzie nam wygodnie, powiedzmy w Pobranych albo w Dokumentach.
    Jeżeli coś nam źle się rozpakuje, to czynność powtarzamy. Utworzy się katalog z flashem 10.
    Następny krok:
    Kopiujemy plik (bez sudo) libflashplayer.so do /home/user/.mozilla/plugins

    Dalej już z sudo;

    W terminalu wpisujemy sudo nautilus albo sudo dolphin, sudo thunar, zależy którego manadźera plików ktoś używa.
    Gdy nam się odpali, tow manadźerze plików kopiujemy plik libflashplayer.so do /usr/lib/mozilla/plugins
    następnie do /usr/lib/opera/plugins o ile ktoś używa opery.
    Kolejny krok, to: kopiujemy (cały czas z uprawnieniami sudo) plik: flash-player-properties do /usr/local/bin

    ..i to wszystko,reset komputera. Działa w firefox, operze, chromium-browser, rekonq. Niestety nie działa w google-chrome, ale myślę, że wystarczy nam to, że kolorki są w chromium.

    Teraz koniec cytatu, bo to był cytat.
    W nowej wersji chrome – 20 (nie chromium) jest już nowy flash. W nim niebieskich kolorków już nie ma, może niektórym po prostu wystarczy zainstalowanie najnowszego chrome, u niektórych źle działa, jak czytam czasem, ale u mnie rewelacja, kartę graficzna mam nvidia – w miarę nowy egzemplarz.

    A porada napisana (skopiowana) powyżej pomaga. Mogę tylko dodać, że w rozpakowanej paczce ze starym flashem jest kilka rzeczy i np. coś, co dotyczy KDE należy też rozpakować do odpowiedniego katalogu, czyli usr/lib/kde4/kcm_adobe_flash_player.so (jest tam taki plik i wkleić go na prawach sudo do usr/lib/kde4 – powodzenia.

  • pablo

    sudo add-apt-repository ppa:tikhonov/misc
    sudo apt-get update
    sudo apt-get install libvdpau1

    lub instalacja Google Chrome

  • Gats

    ja mam u siebie w Chrome Wersja 24.0.1312.52 jeszcze cos innego :

    i tak na kazdym filmie (tylko YouTube i tylko Chrome) wtf ?

    pomocy, ktos wie o co chodzi ?

  • Gats

  • Gats