Wyszukiwanie dostępnych sieci bezprzewodowych

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Aby wyszukać dostępne sieci bezprzewodowe w otoczeniu Twojego komputera, użyj polecenia:

sudo iwlist wlan0 scan

Po chwili zostanie wyświetlona lista dostępnych sieci bezprzewodowych. Teraz, aby połączyć się z siecią użyj polecenia:

iwconfig wlan0 essid nazwa_sieci key klucz_do_sieci

lub (jeśli sieć jest niezabezpieczona):

iwconfig wlan0 essid NAZWA_SIECI

W miejscu nazwa_sieci wpisz to, co widzisz po ESSID (w wynikach pierwszej komendy)
I na koniec:

dhclient wlan0
Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • http://www.zakladobrobki.pl/ jaack

    lul, godzina wstawienia tego artykułu powinna się też wyświetlić ;p
    poza tym, ten klucz, to działa tylko z WEP, z WPA już nie ;)

  • http://www.ubuntu-pomoc.org Szmitas

    0:01, to nie jest żadna tajemnica – większość jest tak publikowana (automat) :)
    Możliwe, nie łączyłem się w ten sposób z sieciami zabezpieczonymi ;p

  • luki81

    cześć wpisałem sudo iwlist wlan0 scan ale wyskoczył komunikat
    wlan0 Interface doesn’t support scanning.
    i żadna sieć się nie pojawiła:(

    L

  • http://www.ubuntu-pomoc.org Szmitas

    Prawdopodobnie problem ze sterownikami. Zainteresuj się aplikacją ndiswrapper

  • Miluś

    A mi po wpisaniu:
    sudo iwlist wlan0 scan
    wyświetliło się :
    wlan0 Interface doesn’t support scanning : Network is down
    Jestem nowymużytkownikiem linuxa i bardzo prosze o pomoc

  • http://www.ubuntu-pomoc.org Szmitas

    Spróbuj najpierw:

    sudo ifconfig wlan0 up

    A potem skanuj.

  • lightboy

    Wyskakuje mi unknow host a wpisuje taką samo nazwe(essid) jak z polecenia scan(zgadzają sie wielkosci liter

  • Maćko

    Hej,

    Nie mogę się połączyć z AP za pomocą terminala

    Komenda:
    sudo iwconfig eth1 essid nazwa_sieci

    Nie zwraca błędów, ale jak sprawdze ifconfig to nie przydziela mi adresu IP.
    Router ma włączony DHCP.

    Po wpisaniu sudo dhclient eth1

    wyskakuje mi coś takiego:
    maciek@Vostro-1700:~$ sudo dhclient eth1
    Internet Systems Consortium DHCP Client V3.1.3
    Copyright 2004-2009 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/

    Listening on LPF/eth1/
    Sending on LPF/eth1/
    Sending on Socket/fallback
    DHCPREQUEST of 192.168.1.4 on eth1 to 255.255.255.255 port 67
    DHCPREQUEST of 192.168.1.4 on eth1 to 255.255.255.255 port 67
    DHCPREQUEST of 192.168.1.4 on eth1 to 255.255.255.255 port 67
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 16
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 19
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 2
    No DHCPOFFERS received.
    Trying recorded lease 192.168.1.4
    PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

    — 192.168.1.1 ping statistics —
    1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

    No working leases in persistent database – sleeping.
    maciek@Vostro-1700:~$ ping wp.pl
    ping: unknown host wp.pl

    Dodam jeszcze że kożystając z Aplet NetworkManager’a łączę się z nim normalnie.