Wydano LibreOffice 3.6.3 i libreoffice-installer 0.2.2

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Wraz z wydaniem LibreOffice 3.6.3 ukazał się nowy instalator mojego autorstwa:

Zmiany w libreoffice-installer 0.2.2

  • Naprawiono błąd uniemożliwiający włączenie integracji z KDE jeżeli instalacja jest nadpisywana

Instalacja

Instalator należy pobrać, nadać mu uprawnienia do wykonywania i uruchomić w terminalu.
Znajduje się on tutaj: http://ubuntu-pomoc.org/libreoffice-installer

Można to zrobić następującymi poleceniami:

mv -f ./libreoffice-installer ./libreoffice-installer.old ; wget http://ubuntu-pomoc.org/libreoffice-installer
chmod +x ./libreoffice-installer && ./libreoffice-installer

Zachęcam do proponowania zmian w komentarzach i przysyłaniu poprawionych wersji skryptu lub łatek na e-mail (projekt nie jest jeszcze w żadnym systemie kontroli wersji).
Więcej szczegółów tutaj: http://www.ubuntu-pomoc.org/libreoffice-installer-0-1-wydany/

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • pavbaranov

    Tak mi się wydaje, że tutaj:
    chmod +x ./libreoffice-installer && ./libreoffice-installer
    Jest błąd i winno być:
    chmod +x libreoffice-installer && ./libreoffice-installer

    • Admc

      Nie, tu nie ma żadnego błędu.

  • http://www.maxxpreston.pl Maxx Preston

    Instalator nadal podaje że jest w wersji 0.2.1.
    Na serwerze jest stara wersja czy autor zapomniał uaktualnić „zmienną” VESRION?

    • Admc

      Omsknięcie ręki przy zmianie numerka, zaraz poprawię ;)

  • firekage

    Z ciekawości – instalacja „installerem” tworzy paczki .deb? Jak rozumiem, instalacja przez wget i chmod +x nie robi tego?

    • Admc

      Nie, instalator nie tworzy paczek, ściąga je z internetu.

      Wget służy do pobierania skryptu a chmod nadaje prawa do wykonywania.

  • Tomek

    Poprzednia wersja instalatora znała polskie litery – teraz wyświetla krzaki. Czy ja mam coś schrzanione?

    • Admc

      U mnie działa…
      Podaj wynik polecenia locale

  • Tomek

    LANG=pl_PL.UTF-8
    LANGUAGE=
    LC_CTYPE=”pl_PL.UTF-8″
    LC_NUMERIC=”pl_PL.UTF-8″
    LC_TIME=”pl_PL.UTF-8″
    LC_COLLATE=”pl_PL.UTF-8″
    LC_MONETARY=”pl_PL.UTF-8″
    LC_MESSAGES=”pl_PL.UTF-8″
    LC_PAPER=”pl_PL.UTF-8″
    LC_NAME=”pl_PL.UTF-8″
    LC_ADDRESS=”pl_PL.UTF-8″
    LC_TELEPHONE=”pl_PL.UTF-8″
    LC_MEASUREMENT=”pl_PL.UTF-8″
    LC_IDENTIFICATION=”pl_PL.UTF-8″
    LC_ALL=

    • Admc

      No to nie wiem, a jak otworzysz w edytorze tekstu to są polskie znaki czy krzaczki?

      • Tomek

        Przepraszam za zabranie czasu – jest dobrze. To ja jak debil zamiast pobrać skrypt przez wget, klikałem na link znajdujący się powyżej i metodą kopiuj-wklej zapisywałem treść w pustym pliku. Jeszcze raz przepraszam.

        • Admc

          Tak też można, po prostu zapisałeś plik ze złym kodowaniem ;) W Linuxie używa się kodowania UTF-8. Windows jest przestarzały i używa CP1250 z lat 80. ubiegłego wieku.

  • dedo

    Na mint-cie
    Skrypt ten jest przeznaczony tylko dla Ubuntu i może nie działać poprawnie na uruchomionym systemie.
    Czy chcesz kontynuować mimo to? [t/N]

    potwierdzając instalacje t zamyka skrypt
    wciskając N – kontynuuje instalacje :)
    (coś się pomieszało przy pisaniu skryptu)

    • Admc

      Przyjrzę się temu później, na tyle błahy błąd że poprawię go przy okazji.

  • cnl

    No mistrzostwo świata! Piękne dziękuję Admc!!! Używam Lubuntu 12.10 (LXDE) i miałem problem z wyglądem tego pakietu, teraz jest genialnie, dziękuję jeszcze raz :)

  • krzemyk

    kiedy będzie nowy installer dla 3.6.4 ?

    • Admc

      Przecież instalator automatycznie wykrywa i pobiera zawsze najnowszą wersję :)

      • Andrzej

        A jaka jest możliwość zainstalowania LO 4.0 Beta2

        • Admc

          Nie ma takiej możliwości, jeśli umiesz pisać w bashu możesz samemu dopisać taką funkcję do skryptu a następnie się podzielić z innymi.

  • Andrzej

    Przykro mi, ale jestem tylko zwykłym użytkownikiem i jadam tylko to, co mam na tacy.SORRY