Wydano LibreOffice 3.5.3, instalacja w Ubuntu

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!
W Ubuntu 12.04 znajduje się już LibreOffice 3.5, które jest zoptymalizowane pod Unity. Wpis jest adresowany do użytkowników innych środowisk niż Unity, gdzie LO zainstalowane ze strony Document Fundation wygląda lepiej.

Wydano LibreOffice 3.5.3. Nowa wersja niesie ze sobą wiele usprawnień i naprawionych błędów. Postanowiłem napisać nowy-stary poradnik jak zainstalować ww. pakiet biurowy na Ubuntu.

  1. Utworzenie i przejście do katalogu tymczasowego:
    mkdir ~/LibreOffice-tmp && cd ~/LibreOffice-tmp
  2. Pobieranie LibreOffice 3.5.3:
    a) 32 bity:

    wget http://download.documentfoundation.org/libreoffice/stable/3.5.3/deb/x86/LibO_3.5.3_Linux_x86_install-deb_en-US.tar.gz http://download.documentfoundation.org/libreoffice/stable/3.5.3/deb/x86/LibO_3.5.3_Linux_x86_langpack-deb_pl.tar.gz http://download.documentfoundation.org/libreoffice/stable/3.5.3/deb/x86/LibO_3.5.3_Linux_x86_helppack-deb_pl.tar.gz

    b) 64 bity:

    wget http://download.documentfoundation.org/libreoffice/stable/3.5.3/deb/x86_64/LibO_3.5.3_Linux_x86-64_install-deb_en-US.tar.gz http://download.documentfoundation.org/libreoffice/stable/3.5.3/deb/x86_64/LibO_3.5.3_Linux_x86-64_langpack-deb_pl.tar.gz http://download.documentfoundation.org/libreoffice/stable/3.5.3/deb/x86_64/LibO_3.5.3_Linux_x86-64_helppack-deb_pl.tar.gz
  3. Rozpakowanie LibreOffice 3.5.2:
    tar -xvzf LibO_3.5.*help* && tar -xvzf LibO_3.5.*install* && tar -xvzf LibO_3.5.*lang*
    
  4. Usuwanie starszej wersji LO (wykonaj tylko, gdy posiadasz wersję z repozytorium Ubuntu, czyli domyślnie instalowaną)
    sudo apt-get remove libreoffice*.*
  5. Instalacja LibreOffice 3.5.3
    sudo su -c "find . -name *.deb | xargs dpkg -i"
  6. Usunięcie katalogu tymczasowego:
    rm -rf ~/LibreOffice-tmp && cd $HOME

Użytkownicy KDE mogą włączyć integrację ze stylem systemowym za pomocą prostego obejścia problemu opisanego tutaj.

Teraz wystarczy tylko przetestować nową wersję pakietu :)

Wydano LibreOffice 3.5.3, instalacja w Ubuntu

LibreOffice 3.5.3

Komendy z tego wpisu można zastosować do zainstalowania nowszych wersji LibreOffica, które pojawią się po opublikowaniu tego artykułu (wystarczy odpowiednio zamienić numerki).

Dlaczego nie napisałem skryptu? Bo wolę żeby ludzie wiedzieli co wpisują do terminala. Większość osób nie czyta lub nie rozumie skryptów które uruchamiają narażając się na niebezpieczeństwo (tak właśnie powstały pierwsze trojany na Linuxa).

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • czytelnik

    Oficjalnie rezygnuję z subskrybcji rss waszego bloga. Zwracałem już na to uwagę w jakichś wcześniejszych artykułach, ale nikt się na błędach widać nie uczy – i to jest powód. Opisujecie zawile zagadnienia, które tak naprawdę są banalne do rozwiązania. Ten blog nie pomaga chyba nikomu, on tylko odstrasza ludzi od wejścia w świat ubuntu (i linuksa jako całości).

    Libre office można zainstalować z palcem w dupie, ale po co o tym mówić, skoro można dać artykuł z tysiącem instrukcji do terminala. To samo tyczy się reszty waszych wypocin. Pa

    • Admc

      W takim razie prosimy w takim razie na podanie jakichś niebanalnych zagadnień, o których można napisać.

      Co do instalacji LibreOffice to lepiej jest podać 6 (słownie: sześć) komend niż opisywać po kolei o tym jak pobrać i jak zainstalować na raz ponad 100 pakietów deb.

      • Tadeusz

        Wystarczy dodać repozytorium LibreOffice:
        sudo add-apt-repository ppa:libreoffice/ppa
        i zaktualizować bazę pakietów:
        sudo apt-get update

        Resztą zajmie się „Menedżer aktualizacji”.

        Po co komplikować ludziom życie?

        • Admc

          W tym PPA jest stara wersja LibreOffice.

          • http://www.netbuntu.pl eMcE

            Zależy dla jakiej wersji systemu. Dla mojego 10.10 są starsze paczki.
            Ale dla 11.x już są nowe.

          • Admc

            Bzdura, w tym PPA jest LO 3.4.5 a nie 3.5.

  • DanielUJ

    Tylko ten blok chyba nie jest dla starych wyjadaczy Ubuntu, tylko dla osób, które zaczynają przygodę z tym systemem?
    Ja jak zaczynałem przygodę z Ubuntu 1,5 roku temu, to nawet nie wiedziałem co to jest repozytorium, a nie mówią już o posługiwaniu się konsolą. Wtedy ten blok był dla mnie bardzo pomocny.

  • van.den.vons

    Baaaaardzo niedopracowana wersja, mimo tego, że już podobno stabilna.
    Po pierwsze, nie chce tworzyć szablonów dokumentów, ani ich modyfikować, itd.
    Po drugie, program „nie trzyma” ustawień użytkownika.
    Po trzecie dramatycznie żadna obsługa makr.
    W poprzednich wersjach albo opisane funkcje działały z „automatu”, albo jakoś udawało mi się do tego doprowadzić. I żeby nikt nie pisał, ze coś robię źle: przetestowałem tę niedorobioną wersję na 3 kompach, stosując porady z tego forum, oraz dwóch innych.

    • Admc

      https://www.libreoffice.org/get-help/bug/

      Prosiłbym też o wyjaśnienie stwierdzenia „dramatycznie żadna”, zaciekawiło mnie to.

      • van.den.vons

        Nie rejestruje makr, nie wykonuje ich. Poza tym… po instalacji okazało się, że program w ogóle nie trzyma ustawień strony, menu, czyli moich indywidualnych ustawień z poprzedniej wersji 3.4.5. Gdy wywaliłem wersję 3.5.0, i wróciłem do 3.4.5 – okazało się, że wszystko jest OK. Program sam z siebie wrócił do moich ustawień. Ta nowa wersja nie pozwala na tworzenie własnych szablonów domyślnych. Jeśli to ma być wersja stabilna, to dziękuję za taką.

        Próbowałem z nią walczyć od wczoraj rano, korzystając z polskich i zagranicznych stron z instrukcjami. Czego bym nie zrobił… efekt ten sam – do kosza.

        • pavbaranov

          Pomijając ewentualne błędy, bo nie testowałem 3.5, to być może nic/niewiele Ci działa, albowiem wszystkie dotychczasowe ustawienia będziesz mieć w innym miejscu niż szuka tego 3.5 z instalacji opisanej powyżej.
          LO z DocumentFundation instaluje się (jeśli pamiętam) domyślnie w /opt, podczas gdy wersja z repozytorium w ~/.libreoffice. Stąd też nowa 3.5 nie przejmie żadnych dotychczasowych ustawień. Można je spróbować przekopiować z drugiego z podanych katalogów w odpowiednie miejsce w /opt, ale nie daję głowy, że się uda.
          I informacji o powyższym w komentowanym tekście (jak i innych w necie) brakuje mi.

          Wersje z oficjalnych repozytoriów oraz z PPA instalują się w ~/.libreoffice. W tej chwili dostępne są:
          1. Dla Precise: PPA Libreoffice: https://launchpad.net/~libreoffice/+archive/ppa
          2. Dla Lucid: PPA Rico Tzschichholza: https://launchpad.net/~ricotz/+archive/ppa
          Dla innych wersji, pewnie niebawem znajdzie się w PPA Libreoffice.

          Przy okazji, w PPA libreoffice wersja 3.5 jest dla precise (teoretycznie, bo zdaje się, że jeszcze jakichś paczek jej brak). Sprawdzę na 12.04.

  • nicodem

    Co ciekawe – u mnie instaluje się 3.5RC3 a nie pełna…

    • Admc

      RC3 = stabilna, tak piszą autorzy na stronie DF.

  • http://mantis.cba.pl mantis

    Jeśli posiadasz 64-bitowy system zamień x86 na x86-64 w komendach.

    nie bardzo, w nazwie pliku tak x86-64
    lecz w nazwie folderu x86_64 ;D proszę popraw Admc

    • Admc

      Racja

  • Tomfoc

    Czy Admc widzi różnicę pomiędzy słowem „jakiś”, a „jakichś”. Złap się za jaja człowieku i naucz pisać po polsku.

    • Admc

      Nie jestem humanistą i nawet nie wiedziałem że tak się pisze. Jestem tylko człowiekiem. Poza tym nie trzeba od razu obrażać autora komentarza.

  • http://xn--rem-bza.com.pl harmageddon

    Wiem, że wielu przeszkadza surowy wygląd open/libre office, ale mi się podoba.

  • http://www.netbuntu.pl eMcE

    Ja instalowałem nieco inaczej..
    Wywalenie starego LO komendą:
    sudo apt-get remove libreoffice-core

    Zaciągnąłem paczki nowego przez przeglądarkę.. wszystkie trzy archiwa (install, langpack i helppack).
    Rozpakowałem spod nautilusa..
    I potem w terminalu przechodzimy do poszczególnych folderów z deb’ami i wykonujemy polecenie:
    sudo dpkg -i *.deb

    Najpierw w głównym folderze instalki (anglojęzycznej), potem w desktop-integration,
    a następnie w folderze z plikami językowymi PL oraz jak ktoś chce, to w folderze
    z plikami helpa.
    Po tym mamy w pełni zainstalowany LibreOffice w polskiej wersji wraz z helpem.

    Powrót do wersji z ubuntowego ppa robimy tak:
    sudo apt-get remove libreoffice3.5* libobasis*

    a następnie:

    sudo apt-get install libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-gnome libreoffice-gtk libreoffice-help-en-us libreoffice-impress libreoffice-math libreoffice-ogltrans libreoffice-style-human libreoffice-writer

    I tyle :)

  • van.den.vons

    Tak jak opisałeś powyżej też próbowałem. Jakkolwiek bym nie instalował wersji 3.5, program nie chce słyszeć o modyfikacji szablonów domyślnych. Nie przyjmuje też rejestracji makr. Dla mnie to istotne, ponieważ tworzę w pracy duże ilości dokumentów. W wersji 3.4.5 utworzyłem sobie szablony domyślne, a zarejestrowane marka przypisałem do klawiszy F1-F8, co umożliwiało mi jednym kliknięciem wstawiać do tekstu znaki specjalne, by nie wpisywać ich poprzez menu „wstaw”, itd. Pozwalało mi to także przyporządkować pod tymi klawiszami wstawianie kolejnych przypisów, itd. Wersja 3.5 nie współpracuje z moimi potrzebami. Czyli… rozwój wsteczny?

    Tak więc, po prawie trzech dniach walki z wersją 3.5 poszła się ona je*** i wróciłem do wersji 3.4.5.

  • http://www.netbuntu.pl eMcE

    Hmm.. nie sprawdzałem tego u siebie.
    No to w takim razie, może zgłoś to jako błąd na launchpadzie, albo przez któreś z for OO/LO.

    • pavbaranov

      eMcE – nie na Launchpadzie, bo wersja z DF nie ma nic wspólnego z Launchpadem, a jak napisałem wyżej, to nie jest błąd.
      Być może rozwiązaniem jest przeniesienie tych makr ręcznie do odpowiedniego katalogu (nie podam rozwiązania, bo nie mam w tej chwili wersji z DF i nie wiem jak nazywają się dokładnie katalogi tworzone w /opt, ale to nie problem i każdy może podglądnąć. Co najwyżej ryzykuje się przeinstalowaniem LO (jeśli ktoś nie zachowa poprzednich ustawień).

  • prozak64

    A mnie najbardziej wkurza drukowanie z libreoffice, aby mieć wybór normalny, która i jaki sposób stronę drukować to muszę najpierw zapisać do pdf, i z tego drukować. Ciągłe wchodzenie we właściwości drukuj i tam zaznaczanie którą stronę wydrukować jest bardzo męczące.

  • prozak64

    formuł matematycznych nie idzie wpisać

    • Admc

      Raportujcie błędy na stronie LibreOffice a nie tutaj. Nie jestem programistą i nie naprawię wam tego.

      • prozak64

        Tu nie chodzi o naprawianie, ale o ocenę czy warto wgrywać ta wersję programu co nie działa w 100%.

  • http://boreksadlak.dyndns.org borek

    Tak trzymać dalej jak dla mnie instalacja poprzez konsolę zawsze się dla treningu przyda.

    PS. formuły działają – przynajmniej na U10.10

  • AdamS1981

    Witam, zaktualizowałem LO, dokumenty się otwierają, ale chyba coś nie do końca poszło tak jak trzeba, ponieważ nic nie ma w Programy -> Biuro -> Zainstalowane. Ponadto używam Cairo Dock, w którym miałem aktywator do LO Writer’a – po aktualizacji ikonka jest, ale program się spod niej nie uruchamia. Proszę o pomoc; z góry dziękuję!

    • Admc

      Nie mam dostępu do twojego komputera więc nie mogę powiedzieć na 100% co się stało ale prawdopodobnie po prostu LO nie jest zainstalowany. Pewnie przyklejałeś komendy na ślepo i nawet nie patrzyłeś czy wszystko poprawnie się wykonało.

      • AdamS1981

        Niby jest zainstalowany – wszystko się uruchamia się, LO zaktualizowany do wersji 3.5.1.2 (wg Pomoc -> Informacje).
        Niestety nie jestem na tyle doświadczonym użytkownikiem Ubuntu, żeby stwierdzić czy wszystko się poprawnie wykonało. Faktycznie, moje działania polegały na kopiuj-wklej do Terminala. Myślałem, że tak ma to wyglądać; widać, nie tędy droga… I co mogę teraz zrobić?

        • AdamS1981

          Udało się!!! Wystarczyło ponownie uruchomić komputer. Przepraszam za zamieszanie. Pozdrawiam

  • http://eczytanie.blox.pl qwert

    Miało być „Człowieczeństwo dla wszystkich” a wyszły poradniki z zaklęciami w konsoli. To wielka porażka projektu Ubuntu.

    • Admc

      Co jest złego w używaniu konsoli? Oczywiście można to zrobić graficznie ale tak jest szybciej. Poza tym LO 3.5 jest już domyślnie zainstalowany w Ubuntu 12.04, ten poradnik powstał z myślą o użytkownikach Ubuntu 11.10

  • http://eczytanie.blox.pl/ czytniki

    Właśnie przez takie poradniki Ubuntu jest postrzegane nie jako system dla ludzi, tylko dla linuksowych Harry Potterów.

    • Admc

      Wiele razy się już odnosiłem do takich komentarzy. Przeczytaj co pisałem wyżej.