[Ubuntu 13.10] Brak dźwięku w Skype

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

skype

Jeśli korzystasz z Ubuntu 13.10 Saucy Salamander i pobrałeś Skype z jego oficjalnej strony, możesz spotkać się z brakiem dźwięku w aplikacji. Błąd ten ma miejsce, ponieważ w Ubuntu 13.10 pracuje PulseAudio 4.0, z którym Skype nie jest w tym momencie w stanie współpracować.

Rozwiązania są dwa – instalacja Skype z repozytorium przeznaczonego dla Ubuntu 13.10 lub konfiguracja.

Rozwiązanie #1 – instalacja Skype z repozytorium

Skype, który znajduje się w repozytorium został skorygowany pod kątem wspomnianego błędu.

  1. Uruchom Centrum oprogramowania Ubuntu.
  2. Z menu Edycja wybierz Zasoby oprogramowania.
  3. W zakładce Inne oprogramowanie odszukaj i zaznacz dwie pozycje – Partnerzy Canonical oraz Partnerzy Canonical (kod źródłowy) – wybór potwierdź podaniem hasła.
    Odszukaj i zaznacz obie pozycje

    Odszukaj i zaznacz obie pozycje

  4. Zamknij Zasoby oprogramowania i Centrum oprogramowania Ubuntu.
  5. Otwórz terminal i zaktualizuj listę pakietów:
    sudo apt-get update
  6. Zainstaluj Skype:
    sudo apt-get install skype

Rozwiązanie #2 – modyfikacja aktywatora

Jeśli nie chcesz instalować Skype z repozytorium, otwórz terminal i wydaj polecenie:

sudo sed -i 's/^Exec=.*/Exec=env PULSE_LATENCY_MSEC=30 skype %U/' /usr/share/applications/skype.desktop
Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • poirytowany

    Mam problem ze Skype odkąd zacząłem używać ubuntu (12.10). Chodzi o to, że osoba do której dzwonię słyszy oprócz mojego głosu, szum, trzaski i ogólnie nie da się normalnie prowadzić rozmów. Ja po swojej stronie wszelkie anomalie dźwięku zlikwidowałem edytując /etc/pulse/default.pa load-module module-udev-detect i dodając na końcu tsched=0 jak ktoś poradził na forum ubuntu. Natomiast problemów po stronie mojego rozmówcy nie jestem w stanie zlikwidować żadnym sposobem. Czytałem, że tego typu problemu występują w laptopach z dwoma mikrofonami. Nie wiem ile w tym prawdy ale na win7 żadnych problemów z dźwiękiem na skype nie było. Przeczytałem chyba wszytko co dotyczy problemów z pulse audio i nadal rozwiązania problemu nie znalazłem.

  • chiquita

    czy nadal trzeba „odwrócić” obraz wbudowanej kamerki? nie instalowałem jeszcze salamandry

  • Michał

    U mnie zadziałało, ubuntu śmiga aż miło.

  • Nowy

    U mnie w zasobach brak: Partnerzy Canonical (kod źródłowy).
    po poleceniu instalacji Skype pojawiają się jakieś błędy o braku skype-bin

  • Jakub

    Mam Ubuntu 13.10 aktualizowane od 12.04 i Skype 4.2.0.11 działa bez żadnego problemu w duecie z PulseAudio 4.0. Co więcej, mam wrażenie, że dźwięk jest czystszy. Więc stwierdzenie z tekstu „w Ubuntu 13.10 pracuje PulseAudio 4.0, z którym Skype nie jest w tym momencie w stanie współpracować” nie może być prawdziwe. W Skype „Urządzenia dźwiękowe: PulseAudio Server (local)”.

  • Paweł

    Miałem ten sam problem po aktualizacji ubuntu z 13.04 na 13.10. Wykonałem w/w komendy i dźwięk w rozmowach powrócił, ale …. zaniknęły dźwięki logowania, połączenia przychodzącego itp. Nie pokazuje się okno rozmowy, tylko wyskakuje małe okienko z powiadomieniem o połączeniu. Co ciekawe dźwięk i okno rozmowy pojawiają się gdy ja inicjuję rozmowę. Czy jest na to sposób.

  • RafciX

    A ja wywaliłem PulseAudio i jadę sobie na Alsie :D
    A dlaczego to zrobiłem? Otóż dlatego, że nie dość, że każda aplikacja, której używam obsługuje Alsę to dodatkowo z PulseAudio zdarzały mi się opóźnienia dźwięku w grach. Aaaa i z odtwarzaniem wielu dźwięków na raz nie mam problemów, a po małej zabawie z plikiem ~/.asoundrc działa mi nawet miksowanie kilku źródeł dźwięku przestrzennego i stereo (który w sumie jest upmix’owany do dźwięku przestrzennego) i oczywiście nie zdarzyły mi się jeszcze opóźnienia. Można? Można!

  • euge

    po tej modyfikacji dziala dzwiek ale zniknal obraz z kamerki

  • Grzegorz

    a jak zrobic by ikonka skype pojawila sie na pasku u gory?

    • http://www.ubuntu-pomoc.org/ Łukasz Schmidtke

      Zainteresuj się tematem odblokowania zasobnika systemowego (traya) – temat poruszany był na naszym blogu.

      • Grzegorz

        dziekuje bardzo, pomoglo :)

  • Mirosław Walczak

    Hej Łukasz,
    Znalazłem tutaj błąd:
    „Uruchom Centrum oprogramowania Ubunut”
    Pozdrawiam,

  • M.D.

    ASUS eeepc 1201HA XUBUNTU 13.10 kernel ver. 3.12.6, problem z dźwiękiem udało mi się rozwiązać metodą kolejnych prób. wchodzimy w program skype > opcje > urządzenia dźwiękowe i zmieniamy „MIKROFON, GŁOŚNIKI, DZWONI” na „analog hardware device with all software conversions” – dźwięk czysty, aż miło [u mnie HDA Intel MID ALC269 Analog]