[Ubuntu 12.04] Instalacja oprogramowania Adobe (Air, Flash, Reader)

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!
Jest to poradnik nadesłany do nas przez jednego z Czytelników – Tripix, dziękujemy!

Ten krótki poradnik ma zamiar pokazać w jaki sposób zainstalować Adobe Flash Player, Acrobat Reader i Adobe AIR w Ubuntu 12.04 (Precise Pangolin). Instalacja tych trzech programów w Ubuntu sprawi, że ​​Twoja praca z systemem będzie przyjemniejsza. Możesz oglądać filmy flash, integrować się z aplikacjami webowymi i przeglądać dokumenty PDF. Ten poradnik ma być krótki i łatwy, bez marnowania Twojego czasu, więc przejdźmy do rzeczy.

Cele

  • Zainstaluj Adobe Flash / Reader / i Air w Ubuntu 12.04,
  • Ciesz się!

Aby rozpocząć, naciśnij Ctrl + Alt + T na klawiaturze, aby otworzyć Terminal. Następnie wpisz poniższe polecenie, by dodać repozytorium Canonical Partner.

sudo apt-add-repository 'deb http://archive.canonical.com/ $(lsb_release -sc) partner'

Następnie wydaj następujące polecenie, aby zaktualizować listę pakietów i zainstalować Adobe Flash Player oraz Adobe Reader.

sudo apt-get update && sudo apt-get install flashplugin-installer acroread

Teraz pobierz Adobe Air:

wget http://airdownload.adobe.com/air/lin/download/latest/AdobeAIRInstaller.bin

Następnie wydaj polecenie poniżej, aby zmienić uprawnienia dla pliku, dzięki czemu będzie wykonywalny.

chmod +x AdobeAIRInstaller.bin

Teraz zainstaluj Adobe AIR:

sudo ./AdobeAIRInstaller.bin

Jeśli operacja się powiodła, wszystko powinno być zainstalowane. Jeśli napotkasz problemy ze środowiskiem Adobe AIR o brak gnome-keyring lub Portfel KDE, uruchom polecenia poniżej, aby to naprawić, a następnie ponownie uruchom instalator Air.

sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

Dla systemów 64-bitowych, skopiuj i wklej to do konsoli.

sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

Teraz uruchom instalator jeszcze raz i ciesz się środowiskiem Adobe Air.
Jednakże po co mi Air, skoro nie wiem jak to wykorzystać?
Na pewno przyda się kilka aplikacji na Adobe Air.

Przypominam, że Adobe Flash i Adobe Air nie są już wspierane na Linux. Są to wersje przestarzałe.
  1. e-Deklaracje – możesz złożyć PIT przez Interent.
  2. WebQQ – Chiński komunikator, ostatnia działająca wersja na Linux to 2009 i to ostatnia wydana wersja, najnowsza 2012 wydana na iOS, Mac OS X i Windows. Dzięki wersji .air instalujesz wersją Web z możliwościami normalnej aplikacji.

    Życzę miłej zabawy.

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • Gregor

    W pierwszym zapytaniu zamiast cudzysłowów powinny być ‚uszy’

    sudo apt-add-repository ‚deb http://archive.canonical.com/ $(lsb_release -sc) partner’

  • Admc

    Adobe Reader też jest już niewspierany i dostępna wersja jest przestarzała.

    • ubuntu-usr

      Co nie zmienia faktu, że bez niego (tak samo jak bez Air, który też nie jest wspierany) nie rozliczymy np. PITu

  • ARNi

    Powinien być poradnik – w jaki sposob trzymać się z dala od „A.Readera „

  • Mlody993

    mlody@Mlody-Ubuntu:~$ sudo ./AdobeAIRInstaller.bin
    /tmp/air.TB9Ehx/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

    Nie działa. :) Wszystkie kroki wykonane poprawnie.

    • Tripix

      sudo aptitude install libgtk2.0-0
      jak pisze ze jest zainstalowany daj

      sudo aptitude reinstall libgtk2.0-0

  • P

    Pod Kubuntu krok instalacji NIE może być wykonany z sudo (występuje jakiś bliżej niekreślony błąd).

  • grek

    u mnie – Podczas instalowania środowiska Adobe AIR wystąpił błąd. Być może administrator nie zezwolił na przeprowadzanie instalacji. Skontaktuj się z administratorem. oczywiśćie wykonane jako sudo, działa to jeszcze ?

    • grek

      działa nie można instalować przez sudo – sam potem pyta o hasło admina. czyli nie
      sudo ./AdobeAIRInstaller.bin
      ale
      ./AdobeAIRInstaller.bin

      tak instaluje się poprawnie. (szkoda że jescze to trzeba instalować – air i adobe niech idą do śmieci html5 rozwiązaniem)

  • Nazca

    U mnie występuje taki problem:

    Error loading the runtime (libnss3.so: cannot open shared object file: No such file or directory)

  • szaman86

    W moim przypadku napotkałem na problem kompatybilności AIR z gnome-keyriong. Podczas instalacji wyskakuje następujący błąd:

    Nie można zainstalować środowiska Adobe AIR. Przed zainstalowaniem środowiska Adobe AIR należy zainstalować aplikację Gnome Keyring lub KDE KWallet.

    Rozwiązanie znalazłem w tym miejscu:
    http://www.debian.pl/archive/index.php/t-26359.html

    Ja zrobiłem tak:
    Poszukałem biblioteki, której nie może znaleźć instalator:

    rafal@rafalski:~$ locate libgnome-keyring.so
    /usr/lib/i386-linux-gnu/libgnome-keyring.so.0
    /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0

    Utworzyłem dwa dowiązania symboliczne:

    root@rafalski:~$ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    root@rafalski:~$ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

    Uruchomiłem instalator Adobe AIR.
    Po zakończeniu instalacji można usunąć dowiązania symboliczne utworzone w pkt 2.

    Źródło (http://www.clarifylinux.org/2012/04/ubuntu-1204-tweak-and-hack-round-up.html)

    • http://www.ubuntu-pomoc.org Łukasz Schmidtke

      Rozwiązanie jest też na naszym blogu. Wystarczyło skorzystać z wyszukiwarki.

  • http://starterx4.xup.pl StarterX4

    thx xd

  • Nibdar

    sudo apt-get install ubuntu-restricted-extras lub sudo apt-get install kubuntu-restricted-extras lub sudo apt-get install xubuntu-restricted-extras lub sudo apt-get install lubuntu-restricted-extras imacie wszystkie potrzebne rzeczy których nie ma, a mieliście je w Windows.

  • Haksio

    ależ to jest gów…
    zamiast kliknąć jakiś plik w rodzaju exe trzeba się męczyć z jakimiś szajsowatymi komendami!!!!!!!!!!

    • Bartek

      Ale na linuxa są pliki w rodzaju exe. W ubuntu mają one rozszerzenie .deb. Uruchamia ci się centrum oprogramowania i instalacje jest przyjemna dla oka. Mnie też zawsze przerażał wiersz poleceń, ale nawet w windowsie są takie przypadki, że trzeba tam zajrzeć ;)

  • lol

    mi nie pobiera flasha pisze co tam not found

  • http://www.lemonit.pl Michał

    Czy to aby na pewno jeszcze działa?