Problem przy aktualizacji wacom-dkms: kod błędu 10

Ostatnio zauważyłem, że wielu użytkowników tabletów wacom (w tym ja) miało problemy z aktualizacją sterownika do tabletów Wacom w Ubuntu 10.10.
Sprawdź, którą wersję jądra Linux masz zainstalowaną:

uname -r

W moim przypadku było to:

2.6.35-22-generic

Teraz wystarczy wydać te trzy polecenia:

sudo mkdir /lib/modules/2.6.32-25-generic
sudo ln /lib/modules/2.6.35-22-generic/build /lib/modules/2.6.32-25-generic/build

Zamień pogrubioną cześć na wynik polecenia uname -r.

sudo apt-get install --reinstall wacom-dkms

Tablety Wacom i gesty

W nowszych wersjach wacom-dkms naprawiono już ten problem. Gesty powinny działać bez grzebania. Niemniej jednak jeżeli dalej nie działają możesz wypróbować poniższy sposób.

W komentarzach dotyczących Ubuntu na pewnym popularnym portalu dotyczącym oprogramowania, ktoś napisał, że Ubuntu nie obsługuje tabletów Wacom. Zasugerowałem, aby zainstalował pakiet wacom-dkms, o którym pisałem w poprzednim wpisie, rozmówca zwrócił mi uwagę, że po zainstalowaniu tego pakietu tablet owszem działa, ale nie działają gesty.

Nigdy nie używałem gestów, bo nie wiedziałem jakie są wygodne dopóki nie kupiłem telefonu z dotykowym ekranem. Obejrzałem film instruktażowy na stronie producenta i okazało się, że gesty działają, ale bardzo trudno się je wykonuje. Mi osobiście na 10 prób udało się tylko raz powiększyć obrazek gestem „szczypania”.

W każdym razie po kilku minutach poszukiwań znalazłem rozwiązanie problemu. Niestety wymaga ono edycji plików źródłowych i ręcznej kompilacji sterownika, innego sposobu nie udało mi się znaleźć. Niemniej jednak spróbuję wytłumaczyć to w sposób jak najbardziej przystępny.

Na początek instalujemy składniki systemu niezbędne do kompilacji:

sudo apt-get install git-core build-essential libx11-dev libxi-dev x11proto-input-dev xserver-xorg-dev libxrandr-dev libncurses5-dev xutils-dev autoconf libtool pkg-config

Łatwa instalacja tabletów Wacom

Jestem szczęśliwym posiadaczem tabletu Wacom Bamboo p&t A6, kupiłem go z myślą żeby dobrze działał pod Ubuntu i gimpem. Surfując po internecie zauważyłem, że prawie wszędzie jest wałkowany sposób, który wymaga ręcznej kompilacji sterownika a na dodatek trzeba kompilować go zawsze kiedy zainstalujemy nowe jądro.
Ostatnio znalazłem sposób, który jest znacznie prostszy i nie wymaga takich kombinacji. Na początek należy zainstalować dkms i nagłówki jądra:

sudo apt-get install dkms linux-headers-`uname -r`

Następnie dodać repozytorium:

sudo add-apt-repository ppa:doctormo/wacom-plus

Zaktualizować listę pakietów: