[Kadu] Skróty globalne – 7 skrótów jest używanych przez inną aplikację

W Ubuntu 12.04 wprowdzono HUD, który aktywuje się przez naciśnięcie klawisza Alt. Gdy klawisz ten jest wykorzystywany w innych aplikacjach np. Kadu, dochodzi do konfliktu:


Masz dwa wyjścia, aby rozwiązać ten „problem”:

  • wyłączenie HUD – opis znajdziesz tutaj,
  • zmiana przycisku aktywującego HUD – opis znajdziesz tutaj.

Możliwe, że pomoże też zmiana skrótów w samej aplikacji, ale chyba wygodniej przestawić HUD, prawda?

[KDE] Ikona Kadu w tray’u

Jest to wpis nadesłany do nas przez jednego z Czytelników – RafciX – dziękujemy!

Zapewne po instalacji najnowszej wersji komunikatora Kadu zauważyłeś, że jego ikona nie znajduje się w tray`u, tylko w rozwijanym menu programu Message Indicator (ikona koperty). Można to łatwo naprawić tworząc krótki skrypt uruchamiający Kadu za pomocą programu ksystraycmd.

[KDE] Ikona Kadu w trayu

Standardowa pozycja ikony Kadu w KDE


Najpierw otwórz terminal i za pomocą polecenia cd przejdź do katalogu, w ktorym chciałbyś umieścić skrypt uruchamiający Kadu. W moim wypadku był to pulpit, więc wpisałem

cd Pulpit

Następnie musisz stworzyć skrypt, o którym była mowa na początku artykułu. W tym celu otwórz plik ze skryptem w terminalowym edytorze tesktu (jeżeli tego pliku nie będzie to zostanie utworzony) za pomocą polecenia:

nano Kadu.sh

Oczywiście zamiast „Kadu” możesz wpisać dowolną nazwę.
Masz otwarty pusty plik ze skryptem. Skopiuj do niego następujący kod:

Kompilacja komunikatora Kadu

Dziś, raczej jako ciekawostkę, opiszę kompilację i instalację Kadu, krok po kroku. Potrzebne jest to, gdy np. chcemy przetestować wersję beta, której nie ma w repozytorium.

Kompilacja komunikatora Kadu

O programie - Kadu skompilowane pod Ubuntu 11.10

  1. Najpierw instalujemy odpowiednie zależności:
    sudo apt-get install build-essential cmake libqt4-dev libx11-dev libxss-dev libxfixes-dev libntrack-qt4-dev libgadu-dev libqca2-dev libqca2-plugin-ossl libindicate-qt-dev zlib1g-dev libidn11-dev libmpdclient-dev libphonon-dev libsndfile1-dev libaspell-dev libqt4-sql-sqlite
  2. Teraz pobieramy paczkę ze źródłami Kadu, a następnie ją wypakowujemy:
    wget http://download.kadu.im/stable/kadu-0.10.0.tar.bz2
    tar xjf kadu-0.10.0.tar.bz2
    

Instalacja emotikon z Gadu-Gadu 10 w Kadu

W poprzednim artykule przedstawiłem sposób instalacji najnowszej wersji Kadu. Dziś zaprezentuję, jak zainstalować emotikony z Gadu-Gadu 10 w Kadu.

Instalacja emotikon z Gadu-Gadu 10

  1. Do terminala wpisujemy:
    wget http://www.pcb.orge.pl/files/kadu-emots_gg10.tar.gz

    aby ściągnąć emotikony.

  2. Pobrane archiwum rozpakowujemy poleceniem:
    tar -zxvf kadu-emots_gg10.tar.gz
  3. Przenosimy emotikony do odpowiedniego katalogu (wymaga podania hasła):
    sudo cp -R emots_gg10 /usr/share/kadu/themes/emoticons/
  4. Teraz w oknie głównym Kadu wchodzimy kolejno do: Kadu → Ustawienia → Wygląd → Emotikony i z listy Zestaw wybieramy emots_gg10. Następnie klikamy Zastosuj i OK.

[Ubuntu 10.04 – 11.04] Instalacja najnowszej wersji multikomunikatora Kadu

W domyślnych repozytoriach Ubuntu nie wszystkie pakiety są w najnowszych wersjach. W tym poradniku zaprezentuję jak, za pomocą paru kliknięć, dodać odpowiednie repozytorium i zainstalować najnowsze Kadu.

Dodanie repozytorium i instalacja najnowszego Kadu

  1. Uruchamiamy terminal i dodajemy oficjalne repozytorium Kadu za pomocą polecenia:
    sudo add-apt-repository ppa:patryk-prezu/ppa
    [11.04] Instalacja najnowszej wersji multikomunikatora Kadu

    Dodawanie nowego repozytorium

  2. Odświeżamy teraz listę paczek dostępnych w repozytoriach:
    sudo apt-get update