Wydano LibreOffice 3.6.3 i libreoffice-installer 0.2.2

Wraz z wydaniem LibreOffice 3.6.3 ukazał się nowy instalator mojego autorstwa:

Zmiany w libreoffice-installer 0.2.2

  • Naprawiono błąd uniemożliwiający włączenie integracji z KDE jeżeli instalacja jest nadpisywana

Instalacja

Instalator należy pobrać, nadać mu uprawnienia do wykonywania i uruchomić w terminalu.
Znajduje się on tutaj: http://ubuntu-pomoc.org/libreoffice-installer

Można to zrobić następującymi poleceniami:

mv -f ./libreoffice-installer ./libreoffice-installer.old ; wget http://ubuntu-pomoc.org/libreoffice-installer
chmod +x ./libreoffice-installer && ./libreoffice-installer

Integracja aplikacji Qt z MATE

Używając MATE zauważyłem, że wszystkie aplikacje napisane przy użyciu Qt nie integrują się z wyglądem systemu. Rozwiązanie problemu jest bardzo proste.

  1. Uruchamiamy terminal i wpisujemy:
    sudo apt-get install qt4-qtconfig
  2. Po instalacji uruchamiamy zainstalowaną aplikację poleceniem:
    qtconfig
  3. Z listy Wybierz styl GUI wybieramy pozycję GTK+
  4. Na koniec wciskamy kombinację klawiszy CTRL + S
Integracja aplikacji Qt z MATE

Efekt końcowy

[Xubuntu 11.10] Integracja wyglądu LibreOffice

Po instalacji LibreOffice w Xubuntu 11.10 mym oczom ukazał się przerażający widok. A oto on:

[Xubuntu 11.10] Integracja wyglądu LibreOffice

LibreOffice nie integruje się z wyglądem Xfce

Rozwiązanie tego problemu jest bardzo proste i ogranicza się do instalacji pakietu libreoffice-gtk. Wystarczy wpisać w terminalu polecenie:

sudo apt-get install libreoffice-gtk

Po instalacji tego pakietu LibreOffice integruje się już z wyglądem Xfce i wygląda normalnie:

[KDE] Naprawa integracji LibreOffice 3.5 z KDE

Jeżeli zainstalowałeś LibreOffice 3.5 i masz środowisko graficzne KDE na pewno zauważyłeś, że pakiet biurowy nie integruje się z motywem KDE.
Przy uruchamianiu LibreOffice w konsoli można zauważyć następujący błąd:

(soffice:PIDprocesu): Gtk-WARNING **: /opt/libreoffice3.5/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/gtk-2.0/2.10.0/engines/liboxygen-gtk.so)

Można to naprawić w bardzo prosty sposób, wystarczy jedna komenda w terminalu:

sudo mv /opt/libreoffice3.5/ure-link/lib/libstdc++.so.6 /opt/libreoffice3.5/ure-link/lib/libstdc++.so.6_orig

Po tej operacji LibreOffice powinien integrować się z KDE.

[KDE] Naprawa integracji LibreOffice 3.4.2 z KDE

LibreOffice Writer integrujący się z KDE