Niespełnione zależności podczas instalacji

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Podczas instalacji aplikacji możesz spotkać się z takim komunikatem:

thunderbird-globalmenu : Wymaga: thunderbird (= 14.0+build1-0ubuntu0.12.04.1) ale 13.0.1+build1-0ubuntu0.12.04.1 jest zainstalowany

Oznacza to, że pakiet, w tym przypadku thunderbird-globalmenu wymaga thunderbird w wersji nowszej, niż jest zainstalowana.
Może też zdarzyć się sytuacja inna:

deluge-console : Wymaga: deluge-common (= 1.3.0-0ubuntu1) ale 1.3.0-1~getdeb1 jest zainstalowany

W systemie zainstalowana jest nowsza wersja pakietu niż ta, wymagana do instalacji.

Rozwiązanie jest zależne od przypadku. W pierwszym przypadku najlepiej zaktualizować listę pakietów oraz system i liczyć na to, że zainstalowana zostanie nowsza wersja aplikacji:

sudo apt-get udpate && sudo apt-get upgrade

Jeśli tak się nie stanie, należy znaleźć repozytorium, w którym znajdzie się nowsza wersja (lub zainstalować ją w inny sposób).

W drugim przypadku można skorzystać z instalacji wcześniejszej wersji pakietu – tak robi się to w Synapticu – Synaptic – wymuszenie wersji pakietu, a tak w terminalu:

sudo apt-get install nazwa_pakietu=wersja

Przykład:

sudo apt-get install deluge-common=1.3.0-0ubuntu1
Instalacja starszej wersji pakietu wiąże się z usunięciem aktualnej.
Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • ARNi

    … można tez wybrać 3 wersję rozwiązania problemu ( którą stosuje Szmitas :) ) , idziemy na piwo i czekamy na wrzucenie paczek do repo .

  • etmoon

    Ta wersja rozwiązania podoba mi się najbardziej.

  • Kpt.Żbik

    apt-get install -f
    Jest jeszcze aptitude, które sobie z tym świetnie radzi.

  • Wizard

    Najlepiej unikać PPA, bo to one zazwyczaj powodują takie problemy. Aptitude też lepiej omijać szerokim łukiem i nie używać go raczej do deinstalacji paczek ;)

  • qnebra

    Może ktoś będzie potrafił doradzić.
    1) W trakcie zmiany jasności ekranu za pomocą klawiszy funkcyjnych nie wyświetla się dymek powiadomienia o tym. Ma on ikonę żarówki i suwak który pokazuje poziom jasności.
    2) W trakcie pracy na baterii nie jest wyświetlany jej stan. W ustawieniach jest włączone jego pokazywanie.
    3) „Jasność i blokada” ma tylko opcje wyłączenia ekranu po nieaktywności i blokada.

  • magic

    a ktoś używa tego badziewnego globalmenu?
    W sumie pewno tak miłośnicy „wynalazku” Unity

  • boguś

    Czy się da nagrać to (http://www.youtube.com/watch?v=8MIb-jZR5QM ) na CD tak żeby słuchać w radiu samochodowym?

  • etmoon

    @Wizard
    Unikać PPA i nie używać aptitude? Dziwna rada, zwłaszcza gdy PPA dają możliwość aktualizacji ulubionych wersji programów lub zwiększenia możliwości systemu. Rada taka byłaby pomocna w przypadku osób, które aktualizują system wraz z wydaniem nowej wersji, wtedy zgodzę się, że to ma sens. Ale dlaczego omijać aptitude?

    @magic
    Globalmenu jest w porządku w przypadku zmaksymalizowanego okna. Przy braku maksymalizacji i pracy na wielu oknach na jednym pulpicie trochę denerwuje. Ale jest zawsze HUD.

  • konrad

    A co jeśli jest taki błąd

    Następujące pakiety mają niespełnione zależności:
    unity-webapps-preview : Wymaga: xul-ext-unity ale nie zostanie zainstalowany
    Wymaga: xul-ext-websites-integration ale nie zostanie zainstalowany
    Wymaga: xul-ext-webaccounts ale nie zostanie zainstalowany
    E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.