Naprawianie uszkodzonych pakietów

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Chwilowy brak prądu podczas instalowania/aktualizacji pakietów może sprawić, że zostaną one uszkodzone. Menedżer aktualizacji zbuntuje się, gdyż nie będzie pracował z uszkodzonymi pakietami. Na szczęście terminal nie jest taki wymagający i pomoże nam w naszej sytuacji, a konkretniej postara się naprawić uszkodzone pakiety.

Aby naprawić uszkodzone pakiety, otwórz terminal i wydaj polecenie:

sudo apt-get install -f
Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • alex

    Po wydaniu komendy:
    sudo apt-get install -f
    Wyrzuciło:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    I dalej są błędy w pakietach…

  • http://www.ubuntu-pomoc.org Szmitas

    Spróbuj tego:

    sudo dpkg --configure --pending

    i ponownie wydaj polecenie:

    sudo apt-get install -f
    • leonov

      Wykonałem te czynności i dalej ten sam komunikat o naprawie uszkodzonych pakietów , mój system Jolicloud 1.2 (dzieje się tak przy próbie instalacji pakietów językowych )

  • kris

    Cześć!
    mam linux mint helena KDE, chciałem sobie zainstalować thunderbirda 3 i poszedłem za jednym ze sposobów, polecanym na wielu stronach i dodałem sobie repozytorium, sęk w tym, że mint stał się oporny na to repo i teraz wyrzuca mi „W: Błąd GPG: http://ppa.launchpad.net karmic Release: Następujące podpisy nie mogły zostać zweryfikowane z powodu braku klucza publicznego: NO_PUBKEY EF4186FE247510BE”, daję mu O.K. i wyskakuje mi „Nie można wykoać zmian!
    Należy najpierw naprawić uszkodzone pakiety.”
    Zrobiłem tak jak zalecasz, sęk w tym, że w terminalu problemu nie ma… Wyskakuje, tylko, że mam kilka nieaktualnych pakietów. Reset kompa nie pomógł. Masz jakiś pomysł?

    Pozdrawiam

  • http://www.ubuntu-pomoc.org Szmitas

    Na początek dodaj brakujący klucz, na stronie znajdziesz na ten temat informacje.

  • Rann

    Powiem szczerze ze jezeli chodzi o linuxa to jestem kompletnie zielony ucze sie go wiec prosze o wyrozumialosc mam ubuntu 10.04 otwieram ubuntu tweak nastepnie centrum oprogramowania, desktop i probuje zainstalowac „Gnome Shell” nastepnie pokazuje mi blad z napisem „Nie można wykonać zmian!
    Należy najpierw naprawić uszkodzone pakiety.” nie wiem czy to mialo jakiis wplyw ale po zainstalowaniu systemu i podaniu mu dostepu do internetu ubuntu instalowal sobie aktualizacje i wtedy bach i brak pradu prosze o pomoc dzieki

  • http://www.ubuntu-pomoc.org Szmitas

    Wykonałeś to, co jest napisane w treści wpisu?

    Piszesz, że jesteś kompletnie zielony, ale o interpunkcję można zadbać.

  • eMcE

    Eh.. też mam jaja z pakietami.. Wywala mi coś takiego:
    Help ;)

    emce@BLASZAK:~$ sudo apt-get install -f
    Czytanie list pakietów… Gotowe
    Budowanie drzewa zależności
    Odczyt informacji o stanie… Gotowe
    0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 4 nieaktualizowanych.
    3 nie w pełni zainstalowanych lub usuniętych.
    Po tej operacji zostanie dodatkowo użyte 0B miejsca na dysku.
    Konfigurowanie language-selector-common (0.6.7) …
    dpkg: błąd przetwarzania language-selector-common (–configure):
    podproces zainstalowany skrypt post-installation zwrócił kod błędu 2
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie language-selector:
    language-selector zależy od language-selector-common (= 0.6.7); jednakże:
    Pakiet language-selector-common nie jest jeszcze skonfigurowany.
    dpkg: błąd przetwarzania language-selector (–configure):
    problemy z zależnościami – pozostawiony nieskonfigurowany
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie ubuntu-desktop:
    ubuntu-desktop zależy od language-selector; jednakże:
    Pakiet language-selector nie jest jeszcze skonfigurowany.
    dpkg: błąd przetwarzania ubuntu-desktop (–configure):
    problemy z zależnościami – pozostawiony nieskonfigurowany
    Przetwarzanie wyzwalaczy dla python-central…
    No apport report written because the error message indicates its a followup error from a previous failure.
    No apport report written because the error message indicates its a followup error from a previous failure.
    Wystąpiły błędy podczas przetwarzania:
    language-selector-common
    language-selector
    ubuntu-desktop
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    emce@BLASZAK:~$ sudo dpkg –configure –pending
    Konfigurowanie language-selector-common (0.6.7) …
    dpkg: błąd przetwarzania language-selector-common (–configure):
    podproces zainstalowany skrypt post-installation zwrócił kod błędu 2
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie language-selector:
    language-selector zależy od language-selector-common (= 0.6.7); jednakże:
    Pakiet language-selector-common nie jest jeszcze skonfigurowany.
    dpkg: błąd przetwarzania language-selector (–configure):
    problemy z zależnościami – pozostawiony nieskonfigurowany
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie ubuntu-desktop:
    ubuntu-desktop zależy od language-selector; jednakże:
    Pakiet language-selector nie jest jeszcze skonfigurowany.
    dpkg: błąd przetwarzania ubuntu-desktop (–configure):
    problemy z zależnościami – pozostawiony nieskonfigurowany
    Przetwarzanie wyzwalaczy dla python-central…
    Wystąpiły błędy podczas przetwarzania:
    language-selector-common
    language-selector
    ubuntu-desktop
    emce@BLASZAK:~$ sudo apt-get install -f
    Czytanie list pakietów… Gotowe
    Budowanie drzewa zależności
    Odczyt informacji o stanie… Gotowe
    0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 4 nieaktualizowanych.
    3 nie w pełni zainstalowanych lub usuniętych.
    Po tej operacji zostanie dodatkowo użyte 0B miejsca na dysku.
    Konfigurowanie language-selector-common (0.6.7) …
    dpkg: błąd przetwarzania language-selector-common (–configure):
    podproces zainstalowany skrypt post-installation zwrócił kod błędu 2
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie language-selector:
    language-selector zależy od language-selector-common (= 0.6.7); jednakże:
    Pakiet language-selector-common nie jest jeszcze skonfigurowany.
    dpkg: błąd przetwarzania language-selector (–configure):
    problemy z zależnościami – pozostawiony nieskonfigurowany
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie ubuntu-desktop:
    ubuntu-desktop zależy od language-selector; jednakże:
    Pakiet language-selector nie jest jeszcze skonfigurowany.
    dpkg: błąd przetwarzania ubuntu-desktop (–configure):
    problemy z zależnościami – pozostawiony nieskonfigurowany
    Przetwarzanie wyzwalaczy dla python-central…
    No apport report written because the error message indicates its a followup error from a previous failure.
    No apport report written because the error message indicates its a followup error from a previous failure.
    Wystąpiły błędy podczas przetwarzania:
    language-selector-common
    language-selector
    ubuntu-desktop
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    emce@BLASZAK:~$

  • Zorba

    Prosze o pomoc.
    sudo apt-get install rapid-photo-downloader
    Terminal :
    Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
    że zażądano niemożliwej sytuacji lub używasz dystrybucji niestabilnej,
    w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
    z katalogu Incoming („Przychodzące”).
    Następujące informacje mogą pomóc rozwiązać sytuację:
    Następujące pakiety mają niespełnione zależności:
    rapid-photo-downloader : Wymaga: python-pyexiv2 (>= 0.3.0) ale nie zostanie zainstalowany
    E: Pakiety są uszkodzone

    Synaptic : Wymaga: python-pyexiv2, ale nie jest on przeznaczony do instalacji

    Guzik prawda : dlaczego ??
    0.1.3-6fakesync1 jest w najnowszej wersji.

    Kwadratura kola ?? O co kaman ??

  • Skrzypas

    dzieki jak cholera, siedzisz w necie i pomagasz ludziom, chwała ci i kasy trzos

  • szykoz1122

    Jak naprawic
    W:Failed to fetch http://ppa.launchpad.net/team-xbmc/unstable/ubuntu/dists/precise/main/source/Sources 404 Not Found
    , W:Failed to fetch http://ppa.launchpad.net/team-xbmc/unstable/ubuntu/dists/precise/main/binary-i386/Packages 404 Not Found
    , E:Some index files failed to download. They have been ignored, or old ones used instead.

  • Kartofelcjan

    Nie naprawiło :( Ubuntu 11.04 na VPSie – Nie idzie zainstalować mysql-server i phpmyadmin :(

    • http://www.ubuntu-pomoc.org/ Łukasz Schmidtke

      Ubuntu 11.04 jest już niewspierane, a repozytoria wyłączone, stąd możliwe problemy.

  • Piotr Lojko

    Nie mogę przeprowadzić aktualizacji do Ubuntu 13.04, pojawia się komunikat „System Pakietów Jest Uszkodzony”

  • kam

    E: Nie udało się uzyskać blokady /var/lib/dpkg/lock – open (11: Zasoby chwilowo niedostępne)

    E: Nie udało się zablokować katalogu administracyjnego (/var/lib/dpkg/), czy inny proces go używa?

    i co teraz???

    • http://www.ubuntu-pomoc.org/ Łukasz Schmidtke

      Sprawdź czy w tle nie pracuje Menedżer aktualizacji lub inne narzędzie wykorzystujące uprawnienia roota.

  • jan katalinski

    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/repo.steampowered.com_steam_dists_precise_steam_i18n_Translation-en
    E: Nie udało się przetworzyć lub odczytać listy pakietów lub pliku stanu.
    E: _cache->open() failed, please report.

    nic z tego niemoge zrozumiec a problem polega na tym ze
    po otwarciu synaptic wyskakuje taki błąd

    po uruchumieniu centrum oprogramowania po kilku sekundach zamyka sie bez komunikatu
    tak jak by go niebyło
    ubuntu 12.10
    niewiem czy jest jeszcze naprawa czy nowy:(system

    prosił bym o jakąs wskazówke pomocy z góry dziekuje

  • jan katalinski

    podejzewam ze musiałem cos kliknąc w usprawnieniach ubuntu tweak

  • Wojtek

    Też lipa:
    wojtek@wojtek-HP-EliteBook-8540w:~$ sudo apt-get install -f
    [sudo] hasło użytkownika wojtek:
    Czytanie list pakietów… Gotowe
    Budowanie drzewa zależności
    Odczyt informacji o stanie… Gotowe
    Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
    linux-headers-4.2.0-16 linux-headers-4.2.0-16-lowlatency
    linux-headers-lowlatency linux-image-4.2.0-16-lowlatency thermald
    Aby je usunąć należy użyć „apt-get autoremove”.
    0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
    12 nie w pełni zainstalowanych lub usuniętych.
    Konieczne pobranie 2272 kB archiwów.
    Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
    Pobieranie:1 http://pl.archive.ubuntu.com/ubuntu/ wily/main libc6-i386 amd64 2.21-0ubuntu4 [2272 kB]
    Pobrano 2272 kB w 0s (2407 kB/s)
    dpkg: błąd przetwarzania pakietu libc6-i386 (–configure):
    pakiet libc6-i386 nie jest gotowy do skonfigurowania
    nie można go skonfigurować (bieżący stan „half-installed”)
    Brak raportu programu apport, ponieważ komunikat błędu wskazuje, że przyczyna niepowodzenia leży w poprzednim błędzie.
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lib32gcc1:
    lib32gcc1 zależy od libc6-i386 (>= 2.2.4); jednakże:
    Pakiet libc6-i386 nie jest zainstalowany.

    dpkg: błąd przetwarzania pakietu lib32gcc1 (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu nvidia-304:
    nvidia-304 zależy od lib32gcc1; jednakże:
    Pakiet lib32gcc1 nie jest jeszcze skonfigurowany.
    nvidia-304 zależy od libc6-i386; jednakże:
    Pakiet libc6-i386 nie jest zainstalowany.

    dpkg: błąd przetwarzania pakietu nvidia-304 (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu nvidia-current:
    nvidia-current zależy od nvidia-304; jednakże:
    Pakiet nvidia-304 nie jest jeszcze skonfigurowany.

    dpkg: błąd przetwarzania pakietu nvidia-current (–configure):
    problemy z zależnościami – pozostaBrak raportu programu apport, ponieważ komunikat błędu wskazuje, że przyczyna niepowodzenia leży w poprzednim błędzie.
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
    wianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lsb-core:
    lsb-core zależy od libc6-i386; jednakże:
    Pakiet libc6-i386 nie jest zainstalowany.

    dpkg: błąd przetwarzania pakietu lsb-core (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lsb-graphics:
    lsb-graphics zależy od lsb-core (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-core nie jest jeszcze skonfigurowany.

    dpkg: błąd przetwarzania pakietu lsb-graphics (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lsb-cxx:
    lsb-cxx zależy od lsb-core (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-core nie jest jeszcze skonfigurowany.

    dpkg: błąd przetwarzania pakietu lsb-cxx (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lsb-multimedia:
    lsb-multimedia zależy od lsb-core (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-core nie jest jeszcze skonfigurowany.

    dpkg: błąd przetwarzania pakietu lsb-multimedia (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lsb-desktop:
    lsb-desktop zależy od lsb-graphics (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-graphics nie jest jeszcze skonfigurowany.
    lsb-desktop zależy od lsb-multimedia (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-multimedia nie jest jeszcze skonfigurowany.

    dpkg: błąd przetwarzania pakietu lsb-desktop (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lsb-printing:
    lsb-printing zależy od lsb-core (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-core nie jest jeszcze skonfigurowany.

    dpkg: błąd przetwarzania pakietu lsb-printing (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lsb-languages:
    lsb-languages zależy od lsb-core (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-core nie jest jeszcze skonfigurowany.

    dpkg: błąd przetwarzania pakietu lsb-languages (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu lsb:
    lsb zależy od lsb-core (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-core nie jest jeszcze skonfigurowany.
    lsb zależy od lsb-graphics (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-graphics nie jest jeszcze skonfigurowany.
    lsb zależy od lsb-cxx (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-cxx nie jest jeszcze skonfigurowany.
    lsb zależy od lsb-desktop (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-desktop nie jest jeszcze skonfigurowany.
    lsb zależy od lsb-printing (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-printing nie jest jeszcze skonfigurowany.
    lsb zależy od lsb-languages (>= 4.1+Debian11ubuntu8); jednakże:
    Pakiet lsb-languages nie jest jeszcze skonfigurowany.

    dpkg: błąd przetwarzania pakietu lsb (–configure):
    problemy z zależnościami – pozostawianie nieskonfigurowanego
    Wystąpiły błędy podczas przetwarzania:
    libc6-i386
    lib32gcc1
    nvidia-304
    nvidia-current
    lsb-core
    lsb-graphics
    lsb-cxx
    lsb-multimedia
    lsb-desktop
    lsb-printing
    lsb-languages
    lsb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  • Fryderyk Almert

    Po wpisaniu w terminal komendy: sudo apt-get update

    wyrzuca mi takie coś:

    E: Typ „sudo” jest nieznany w linii 1 listy źródeł /etc/apt/sources.list.d/mono-xamarin.list
    E: Nie udało się odczytać list źródeł.
    Czy ktoś może mi pomóc?

  • grzechu

    grzechu@grzechu-PCG-K415B:~$ sudo apt-get install -f
    [sudo] password for grzechu:
    Czytanie list pakietów… Gotowe
    Budowanie drzewa zależności
    Odczyt informacji o stanie… Gotowe
    Naprawianie zależności… Gotowe
    Następujący pakiet został zainstalowany automatycznie i nie jest już więcej wymagany:
    libntdb1
    Aby go usunąć należy użyć „apt-get autoremove”.
    Zostaną zainstalowane następujące dodatkowe pakiety:
    linux-headers-3.13.0-87
    Zostaną zainstalowane następujące NOWE pakiety:
    linux-headers-3.13.0-87
    0 aktualizowanych, 1 nowo instalowanych, 0 usuwanych i 4 nieaktualizowanych.
    3 nie w pełni zainstalowanych lub usuniętych.
    Konieczne pobranie 0 B/8876 kB archiwów.
    Po tej operacji zostanie dodatkowo użyte 63,5 MB miejsca na dysku.
    Kontynuować? [T/n] n
    Przerwane.
    grzechu@grzechu-PCG-K415B:~$ sudo apt-get install -f
    Czytanie list pakietów… Gotowe
    Budowanie drzewa zależności
    Odczyt informacji o stanie… Gotowe
    Naprawianie zależności… Gotowe
    Następujący pakiet został zainstalowany automatycznie i nie jest już więcej wymagany:
    libntdb1
    Aby go usunąć należy użyć „apt-get autoremove”.
    Zostaną zainstalowane następujące dodatkowe pakiety:
    linux-headers-3.13.0-87
    Zostaną zainstalowane następujące NOWE pakiety:
    linux-headers-3.13.0-87
    0 aktualizowanych, 1 nowo instalowanych, 0 usuwanych i 4 nieaktualizowanych.
    3 nie w pełni zainstalowanych lub usuniętych.
    Konieczne pobranie 0 B/8876 kB archiwów.
    Po tej operacji zostanie dodatkowo użyte 63,5 MB miejsca na dysku.
    Kontynuować? [T/n] t
    (Odczytywanie bazy danych … 136139 plików i katalogów obecnie zainstalowanych.)
    Preparing to unpack …/linux-headers-3.13.0-87_3.13.0-87.133_all.deb …
    Unpacking linux-headers-3.13.0-87 (3.13.0-87.133) …
    dpkg-deb (podproces): nie można skopiować członu archiwum z „/var/cache/apt/archives/linux-headers-3.13.0-87_3.13.0-87.133_all.deb” do potoku dekompresyjnego: nie udało się odczytać (Błąd wejścia/wyjścia)
    dpkg-deb (podproces): dekompresowanie członu archiwum: błąd lzma: niespodziewany koniec wejścia
    dpkg-deb: błąd: podproces zwrócił kod błędu 2
    dpkg: error processing archive /var/cache/apt/archives/linux-headers-3.13.0-87_3.13.0-87.133_all.deb (–unpack):
    nie można skopiować wypakowanych danych „./usr/src/linux-headers-3.13.0-87/drivers/video/Kconfig” do „/usr/src/linux-headers-3.13.0-87/drivers/video/Kconfig.dpkg-new”: niespodziewany koniec pliku lub strumienia
    Wystąpiły błędy podczas przetwarzania:
    /var/cache/apt/archives/linux-headers-3.13.0-87_3.13.0-87.133_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)