Modem Huawei E1820 – problem z połączeniem

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Sprzedawcy internetu bezprzewodowego oferują nam nowy internet w sieci 4G z którego możemy korzystać za pomocą Modemu HUAWEI E1820. Większość użytkowników ma problem z uruchomieniem takiego modemu i połączeniem z siecią. Jednak znalazło się rozwiązanie tego problemu.

Na początku musimy podłączyć modem. Potem wystarczy uruchomić terminal i wpisać w nim polecenie:

lsusb

Powinien nam się ukazać nam się komunikat:

Bus 001 Device 004: ID 12d1: 1446 Huawei Technologies Co., Ltd.

Teraz otwórz terminal i wydaj polecenie:

sudo gedit /etc/usb_modeswitch.d/12d1: 1446

W oknie które nam się pojawi wpisujemy:

################################################## ######
# Huawei E1820
DefaultVendor = 0x12d1
DefaultProduct = 0x1446
# TargetVendor = 0x12d1
# TargetProductList = "1001,1406,140 B, 140C, 1412.141 b, 14ac"
TargetClass = 0xff
CheckSuccess = 20
MessageContent = "55534243123456780000000000000011060000000000000000000000000000"

Teraz w konsoli wpisujemy:

sudo gedit /lib/udev/rules.d/40-usb_modeswitch.rules

I dodajemy ten o to wpis:

Attrs {idVendor} == "12d1", attrs {idProduct} == "1446", RUN + = "usb_modeswitch '% b /% k'"

Na koniec musimy tylko uruchomić ponownie komputer. Jeśli ktoś miałby problem w Gnome z „gedit” może zastąpić to polecenie tym „nano”.

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.