Łatwa instalacja tabletów Wacom

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Jestem szczęśliwym posiadaczem tabletu Wacom Bamboo p&t A6, kupiłem go z myślą żeby dobrze działał pod Ubuntu i gimpem. Surfując po internecie zauważyłem, że prawie wszędzie jest wałkowany sposób, który wymaga ręcznej kompilacji sterownika a na dodatek trzeba kompilować go zawsze kiedy zainstalujemy nowe jądro.
Ostatnio znalazłem sposób, który jest znacznie prostszy i nie wymaga takich kombinacji. Na początek należy zainstalować dkms i nagłówki jądra:

sudo apt-get install dkms linux-headers-`uname -r`

Następnie dodać repozytorium:

sudo add-apt-repository ppa:doctormo/wacom-plus

Zaktualizować listę pakietów:

sudo apt-get update

I zainstalować wacom-dkms:

sudo apt-get install wacom-dkms

W razie problemów z instalacją pakietu wacom-dkms zajrzyj tutaj: http://www.ubuntu-pomoc.org/problem-przy-aktualizacji-wacom-dkms-kod-bledu-10/

Po tych operacjach należy zrestartować komputer. Po restarcie tablet powinien działać, teraz wystarczy tylko skonfigurować odpowiednio gimpa. Aby tego dokonać należy wejść w Edycja > Preferencje, przejść na zakładkę Urządzenia wejściowe i kliknąć na Konfiguruj dodatkowe urządzenia wejściowe. W moim przypadku należało to ustawić tak:

Łatwa instalacja tabletów Wacom

Od teraz wszystko już powinno działać, włącznie z wykrywaniem nacisku.
Miłego rysowania! ;)

Zainteresowanych zapraszam do przeczytania artykułu pokazującego jak aktywować gesty w tabletach Wacom.

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • http://ikari.digart.pl/digarty/ bialyikar

    Ja nie instaluje żadnych sterowników i wszystko działa normalnie. Zresztą dlatego przeszedłem właśnie na Ubuntu, bo tablety Wacom działały ponoć na nim Out Of Box. Ostatnio doinstalowałem tylko program do konfiguracji przycisków, bo z nimi miałem problemy.
    Co to jest to „dkms i nagłówki jądra”?

    • Admc

      Ten sposób tyczy się tylko najnowszych tabletów Wacom. Skoro działa out-of-box to znaczy, że masz stary tablet.
      Każdy program posiada swoje nagłówki, które określają jakie kompilatory i biblioteki są niezbędne do skompilowania programu.
      DKMS (Dynamic Kernel Module Support) to framework umożliwiający szybkie „dokompilowanie” modułu do istniejącego jądra bez ingerencji człowieka.

  • http://ikari.digart.pl/digarty/ bialyikar

    Nadmienię tylko jeszcze, że posiadam Intous 3 a nie Bambob.

  • lk82

    czy w meerkat ten tablet działa out0of-box? czy touch C dziala wg. tej metody?

    • Admc

      Prawdopodobnie tak ale nie mogę niczego zagwarantować ;)

  • Grze

    A ja wkurzyłem się na linuxa generalnie a na ubu w szczególności. niby jako system jest ok, uzywam od czasów „dziewiątki”. zainstalowałem 10.10. niby fajnie, ale potwierdzam to, co napisał na forum ubuntu.pl pewien gość – na windzie wszystko działa bez zastanawiania się. instalujesz i tyle (też uzywal ubu, ale sie wkurzył – jak ja – bo miał robotę do zrobienia i nie działał mu tablet). Ja roboty ie mam, a też się wkurzam (tablet pentagram p2004).

    rozumiem, że producenci sprzętu i prgramów nie wspierają linuxów, że wiele rzeczy jest robionych na czuja (brak dostępu do kodu, sterowników), wiele w wolnym czasie itp.
    Ale prawda jest taka:
    linux nigdy nie będzie popularnym programem, bez względu na dystrybucję, dopóki nie będzie plug’n’play. Normalni ludzie tego „nie kupią” nawet za darmo, jeśli z każdym sprzętem poza myszą będą musieli się gryźć i drapać… nawet oprogramowanie – sorry za słownictwo – do dupy. w 9-tce musiałem ekstra nagrzebać się, żeby skype zadziałał. w 10.10 xvidcap nie działa audio, w gtkcapture działa, ale za to video jest przyśpieszone ze sto razy, i tak co chwilę…
    kocham linuxy za darmowość, ale daleko im do profesjonalności np. os-a maców.
    podsumowując – fatalny PiaR…

    • Admc

      Dziękuje za komentarz, ale to nie jest miejsce do wylewania swoich żali.
      Moim zaniem wpisanie czterech komend w terminalu jest łatwiejsze niż instalacja sterowników na windowsie.
      Na przyszłość kupuj sprzęt którego producent wspiera linuxa, unikniesz problemów. Kiedy kupowałem tablet, znajomy polecił mi pentagrama. Sprawdziłem, że nie działa pod linuxem. Kupiłem więc wacoma, gdzie instalacja sterowników jest prostsza niż na windowsie.

      Gadasz o plug’n’play, tak na prawde linux ma lepszy plug’n’play niż windows. Przykład, na linuxie kamerka internetowa mojego kolegi działa bez instalowania sterowników, na windowsie trzeba je instalować.

      Co do skype to niech zgadnę, musiałeś zmodyfikować aktywator i włączyć pleloading biblioteki konwertującej obraz wideo na obsługiwany przez skype. Rzeczywiście kupa roboty, po z tym to wine twórców skypea, że nie dostosowali go do nowej biblioteki.

      Do nagrywania dobry jest gtk-record-my-desktop. A jakbyś przeczytał dokumentację xvidcapa to dowiedziałbyś się dlaczego nie ma dźwięku.

      Nie używam Windowsa już dwa lata i myślę, że dobrze wybrałem, system ten spełnia moje oczekiwania.

  • outskywalker

    zasadniczo na wacom bamboo fun i ubuntu natty (11.04) opisany przez Ciebie sposób nie działa – schrzanione repozytorium? ja coś robię źle? nie mam pojęcia – tak czy inaczej dostaję komunikat nieznalezienia sterów (mimo próby zainstalowania) i na tym sprawa się kończy…

    • Admc

      Prawdopodobnie repozytorium nie jest jeszcze gotowe. Możesz ręcznie skompilować sterownik. Jeśli nie wiesz jak to zrobić, mogę ci podać komendę która to zrobi.

      • elmirka

        Niestety ja również mam problemy ze sterownikami pod 11.04, zatem jeżeli ktoś jest w stanie mi pomóc, to bardzo proszę o odp. z konkretnym rozwiązaniem.

        • Admc

          Zainstaluj Ubuntu 12.04, to jest najprostsze rozwiązanie.

  • 0utsider

    Mam problem. Po dodaniu repo i wklepaniu „sudo apt-get update” wywala mi ten błąd:

    W: Nie udało się pobrać http://ppa.launchpad.net/doctormo/wacom-plus/ubuntu/dists/saucy/main/binary-amd64/Packages 404 Not Found

    W: Nie udało się pobrać http://ppa.launchpad.net/doctormo/wacom-plus/ubuntu/dists/saucy/main/binary-i386/Packages 404 Not Found

    E: Nie udało się pobrać niektórych plików indeksu, zostały one zignorowane lub użyto ich starszej wersji.