[KDE] Naprawa integracji LibreOffice 3.5 z KDE

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Jeżeli zainstalowałeś LibreOffice 3.5 i masz środowisko graficzne KDE na pewno zauważyłeś, że pakiet biurowy nie integruje się z motywem KDE.
Przy uruchamianiu LibreOffice w konsoli można zauważyć następujący błąd:

(soffice:PIDprocesu): Gtk-WARNING **: /opt/libreoffice3.5/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/gtk-2.0/2.10.0/engines/liboxygen-gtk.so)

Można to naprawić w bardzo prosty sposób, wystarczy jedna komenda w terminalu:

sudo mv /opt/libreoffice3.5/ure-link/lib/libstdc++.so.6 /opt/libreoffice3.5/ure-link/lib/libstdc++.so.6_orig

Po tej operacji LibreOffice powinien integrować się z KDE.

[KDE] Naprawa integracji LibreOffice 3.4.2 z KDE

LibreOffice Writer integrujący się z KDE

Źródło: svenseidel.net
Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • Savpether

    W Kubuntu 11.10 ten trick nie działa, jeśli nie miałbyś nic przeciwko to proponowałbym zaktualizować ten wątek.

    • Admc

      LibreOffice w Kubuntu 11.10 integruje się bez grzebania. Przynajmniej u mnie :3

      • Savpether

        U mnie to wygląda następująco:
        http://www.imghost.pl/?id=989038916b

        • Admc

          Lepszej intergracji nie będzie, chyba że odinstalujesz wersję z repo i zainstalujesz tą ze strony.

          • Savpether

            Dlaczego to by miało niby pomóc?

        • Admc

          Ponieważ LibreOffice z repo jest spatchowane tak żeby dobrze wyglądało i działało z unity, np usunęli cienie w menu kontekstowym, bo w unity ich nie ma. Niestety odbija się to na integracji z KDE.

  • RafciX

    Zgodnie z tym co mi poradził Admc w artykule http://www.ubuntu-pomoc.org/kde-oxygen-gtk-integracja-aplikacji-gtk-2-i-3-w-kde/ (ostatni komentarz) zastosowałem tą poradę do programu OpenOffice.org 3.3 (najnowszy, instalowałem go z paczek *.deb) i zadziałało :) Polecenie było takie same z tym wyjątkiem, że musiałem zmienić fragment libreoffice3.4 na openoffice.org3 (domyśliłem sie to po błędach). Oczywiście idealne to nie jest, ale OpenOffice.org wygląda teraz o wiele lepiej.
    Jedyne co wypisuje w konsoli to:

    Gtk-Message: Failed to load module „canberra-gtk-module”

    Sam nie wiem skąd wziąść ten „canberra-gtk-module”.

    • Admc

      A dlaczego nie zainstalujesz LibreOffice? Moim zdaniem jest znacznie lepszy niż OpenOffice

      • RafciX

        Po postu jestem jakoś przywyczajony do OpenOffice.org`a i wolę go nie zmieniać na coś innego ;)
        Z canberra-gtk-module poradziełem sobie wpisując to polecenie w terminalu: sudo apt-get install libcanberra-gtk-module i teraz nie wywala mi tego błędu, o którym pisałem w moim poprzednim komentarzu.

        • Admc

          LibreOffice to OpenOffice ze zmienioną nazwą i logiem. Jest znacznie szybszy i poprawiono wiele błędów.

  • http://krzysztofbender.tk Krzysztof Bender

    Integracja Libreoffice 3.5
    sudo mv /opt/libreoffice3.5/ure-link/lib/libstdc++.so.6 /opt/libreoffice3.5/ure-link/lib/libstdc++.so.6_orig

    • Admc

      Dzięki ;)

  • Pingback: Ubuntu - pomoc | Wydano LibreOffice 3.5.2, instalacja w Ubuntu()