Instalacja Unity 2D w Ubuntu 10.10 oraz 11.04

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Środowisko graficzne dla Ubuntu 11.04 zostało już dawno wydane. Wzbudziło to sporo kontrowersji, ale wszelkie protesty nie zdadzą się już na nic.
Unity 2D nie jest wersją środowiska, która będzie domyślnie instalowana w Ubuntu 11.04. Jest to lżejszy i szybszy odpowiednik Unity, który nie wymaga grafiki 3D, więc powinien działać wszędzie bez zarzutu.
Unity 2D wykorzystuje Qt i Qml. Zostało stworzone specjalne repozytorium dla Ubuntu 10.10 i 11.04, dzięki czemu instalacja jest bardzo prosta.

Krok 1. Zainstaluj dwa pakiety: libqtdee i libqtgconf. W tym celu otwórz terminal i wydaj polecenia:
i386:

wget https://launchpad.net/~unity-2d-team/+archive/unity-2d-daily/+build/2152860/+files/libqtdee_0.0~bzr12_i386.deb
wget https://launchpad.net/~unity-2d-team/+archive/unity-2d-daily/+build/2152865/+files/libqtgconf_0.0~bzr30_i386.deb
sudo dpkg -i libqtdee*.deb libqtgconf*.deb
sudo apt-get install -f

amd64:

wget https://launchpad.net/~unity-2d-team/+archive/unity-2d-daily/+build/2152859/+files/libqtdee_0.0~bzr12_amd64.deb
wget https://launchpad.net/~unity-2d-team/+archive/unity-2d-daily/+build/2152864/+files/libqtgconf_0.0~bzr30_amd64.deb
sudo dpkg -i libqtdee*.deb libqtgconf*.deb
sudo apt-get install -f

Konieczne może również okazać się zainstalowanie pakietów libdee-1.0-0 oraz libqt4-declarative:

sudo apt-get install libdee-1.0-0 libqt4-declarative
Informacja: jeśli powyższe linki do pobrania pakietów wygasną, możesz pobrać je bezpośrednio ze strony https://launchpad.net/

Krok 2. Dodaj repozytorium Unity 2D:

sudo add-apt-repository ppa:unity-2d-team/unity-2d-daily

Krok 3. Zaktualizuj system i zainstaluj środowisko:

sudo apt-get update
sudo apt-get install unity-qt-default-settings

Pamiętaj, aby podczas ponownego logowania wybrać Unity Qt jako startową sesję.

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • http://ikari.digart.pl/digarty/ bialyikar

    Dziś zainstalowałem u siebie. Fajny pomysł, wielu osobą może przypaść do gustu, o ilę zwiększą personalizację środowiska i dopracują jeszcze kilka rzeczy. Niestety, wydaje mi się, że będzie tak samo jak w momencie kiedy wprowadzili przyciski nawigacyjne po lewej stronie okna. Bezsensownie wprowadzili ułomną funkcjonalność, tłumacząc się, że ma to na celi wprowadzenie po drugiej stronie okna innych apletów. Fajnie, ale dlaczego tych przycisków nie przesunęli jak już wszystko było gotowe? Podobnie będzie z Unity, niby będzie działać, ale brakować będzie kupy rzeczy :/

  • http://ikari.digart.pl/digarty/ bialyikar

    Ciekawe jest to, że po przelogowaniu się z Unity do Gnoma (uruchomieniu ponownie komputera), pod klawiszem Super (Windows) mam dostęp do programów i katalogów z Unity :)

  • emeritus

    Ja niestety musiałem wrócić do 10.04.Po wgraniu 10.10 każda nowa aktualizacja powodowała kolejny problem.Za którymś razem włożyłem po prostu do napędu płytkę z 10.04 LTS i wcisnąłem restart.Od tego czasu mam święty spokój.Co do UNITY to poczekam na 11.04 i zobaczę.nie zależy mi na 3D mogą być dwa wymiary byle toto śmigało.Jak mi nie podejdzie UNITY zawsze mogę wrócić do GNOME albo przesiąść się na inne distro.I to jest właśnie w Linuksie najfajniejsze.

  • http://google-os.pl/ Dawid Guzicki

    ciekawe zaraz samemu to sprawdzę..

  • http://music.fromby.net/chart/ klm

    Na moim starym laptopie to Unity 2D chodzi koszmarnie wolno…

  • zawis

    Zainstalowałem u siebie Unity2D, fajnie ale nie wiem czy chcę go mieć w 11.04 jakoś mi nie leży.

  • piotrsz78

    Pytanie. Przełączając w Unity na Firefox-a ciągle maksymalizuje mi jego okno. Tylko przy Firefox. Pozostałe programy zachowują się normalnie. Wyłączenie dodatku Unity dla F. nic nie zmienia. Czym to może być spowodowane?

  • Czeslaw

    Na 10.10 można to zrobić sudo apt-get install unity

  • http://szymonbielski.pl szym-szym

    Masakra Unity 12.04 chodzi jak flaki z olejem, a to wyszukiwanie jest po prostu koszmarnie nie wygodne – po 2 miesiącach wróciłem do 10.10

    • http://www.ubuntu-pomoc.org Szmitas

      … które od miesiąca nie jest już wspierane.