Instalacja dodatkowych kodeków

Do poprawnego odtwarzania filmów potrzebne są odpowiednie kodeki. Aby zainstalować niezbędne kodeki otwórz terminal (Aplikacje > Akcesoria > Terminal) i wydaj polecenie:

sudo apt-get install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg
gstreamer0.10-gl gstreamer0.10-plugins-base gstreamer0.10-plugins-good
gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse
gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse
libxine-extracodecs w32codecs

Odczekaj, aż kodeki zostaną zainstalowane. Uruchom ponownie komputer.

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • kamilmroz12

    niestety mi sie nie udało zainstalowac tych kodekow, otrzymałem komunikat:

    kamil@kamil-desktop:~$ sudo apt-get install gstreamer0.10-pitfdll gstreamer0.10-ffmpeggstreamer0.10-gl gstreamer0.10-plugins-base gstreamer0.10-plugins-goodgstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiversegstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverselibxine-extracodecs w32codecs
    Czytanie list pakietów… Gotowe
    Budowanie drzewa zależności
    Odczyt informacji o stanie… Gotowe
    gstreamer0.10-pitfdll jest już w najnowszej wersji.
    E: Nie udało się odnaleźć pakietu gstreamer0.10-ffmpeggstreamer0.10-gl
    kamil@kamil-desktop:~$

    pomocy

  • http://ubuntu-pomoc.org Szmitas

    Zainstaluj pakiety pojedyńczo, może instalator sam „dociągnie” pozostałe. Pozdrawiam.

  • kamilmroz12

    spróbowałem… i oto efekt:/ :

    kamil@kamil-desktop:~$ sudo apt-get install w32codecs
    [sudo] password for kamil:
    Czytanie list pakietów… Gotowe
    Budowanie drzewa zależności
    Odczyt informacji o stanie… Gotowe
    Pakiet w32codecs nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
    Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
    pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.
    E: Pakiet w32codecs nie ma kandydata do instalacji

  • http://ubuntu-pomoc.org Szmitas

    A aktualne repozytoria masz? Jaka wersja systemu?

  • kamilmroz12

    wersja: ubuntu 8.10, jadro: 2.6.27-8-eeepc

  • http://ubuntu-pomoc.org Szmitas

    Wrzuć repozytoria z tej strony i wpisz komendy jeszcze raz. Wklej obowiązkowe i bardzo przydatne.

  • kamilmroz12

    jak to zrobic? jestem nowicjuszem:(

  • http://ubuntu-pomoc.org Szmitas
  • kamilmroz12

    prawie wszystkie kodeki zainstalowaly sie, ale problem z w32 pozostal…

  • http://ubuntu-pomoc.org Szmitas

    Spróbuj tego – klik

  • kamilmroz12

    kamil@kamil-desktop:~$ sudo wget http://www.medibuntu.org/sources.list.d/intrepid.list output-document=/etc/apt/sources.list.d/medibuntu.list
    –2009-04-27 19:08:02– http://www.medibuntu.org/sources.list.d/intrepid.list
    Translacja http://www.medibuntu.org... 87.98.242.110
    Łączenie się z http://www.medibuntu.org|87.98.242.110|:80… połączono.
    Żądanie HTTP wysłano, oczekiwanie na odpowiedź… 200 OK
    Długość: 230
    Zapis do: `intrepid.list.3′

    100%[======================================>] 230 –.-K/s w 0s

    2009-04-27 19:08:03 (3,07 MB/s) – zapisano `intrepid.list.3′ [230/230]

    –2009-04-27 19:08:03– http://output-document=/etc/apt/sources.list.d/medibuntu.list
    Translacja output-document=… nieudane: Name or service not known.
    wget: nie udało się rozwiązać adresu hosta `output-document=’
    ZAKOŃCZONO –2009-04-27 19:08:03–
    Pobrano: 1 plików, 230 w 0s (3,07 MB/s)
    nie mam pojęcia co jest nie tak:(

  • kamilmroz12

    dokonałem aktualizacji systemu z nowa lista repozytoriów i problem zniknął:)