GIMP 2.7.3 został wydany!

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Kilka dni temu została wydana nowa wersja popularnego programu graficznego GIMP (GNU Image Manipulation Program). Oczywiście można ją pobrać z oficjalnej strony GIMP’a, ale pokażę w tym artykule jak zainstalować najnowszą wersję w Ubuntu 11.04 przy użyciu PPA.

Zaczynamy!

  1. Jeżeli posiadamy już starszą wersję GIMP’a, to usuwamy ją za pomocą polecenia:
    sudo apt-get autoremove gimp

    Podobno istnieje możliwość aktualizacji ze starszej wersji, ale u mnie GIMP był pomijany, jedynie instalowane były najnowsze wersje jego zależności (co skutkowało tym, że GIMP nie uruchamiał się, ponieważ starsza wersja wymagała starszych wersji zależności).

  2. Teraz dodajemy nowe PPA:
    sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn
  3. Następnie odświeżamy listę pakietów i instalujemy GIMP’a (już w najnowszej wersji):
    sudo apt-get update
    sudo apt-get install gimp
  4. To wszystko, możemy używać GIMP’a w najnowszej wersji.

Nie wspomniałem o tym wcześniej, ale najnowsza wersja wprowadza możliwość pracy w jednym oknie (rozwiązanie znane z Photoshopa i innych programów graficznych). Aby z niej skorzystać należy w GIMP’ie kolejno wybrać Okna → Tryb jednookienkowy.

GIMP 2.7.3 został wydany!

Najnowsza wersja GIMP - tryb jednookienkowy

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • Admc

    Warto wspomnieć że jest to wersja ROZWOJOWA NIESTABILNA. Dopiero gimp z gałęzi 2.8 będzie stabilny.

    • bialyikar

      Denerwujące jest to, że wszyscy w swoich poradnikach, jak zainstalować najnowszego Gimpa nie wspominają o tym, że ro nie jest wersja stabilna.
      Tryb jednego okna jest wprowadzony do wersji testowych już od dawna.

  • EuGene

    EEeee… ale ja mam już tę wersję (z tegoż właśnie repo) od ładnych kilku miechów (ze 3 co najmniej).. skąd info, że WŁAŚNIE został wydany?

    • EuGene

      Zwracam honor – chyba nie zauważyłem kiedy się zaktualizował. Tak czy inaczej, tryb jednookienkowy nadal działa jak kupa. Po każdym wyłączeniu programu trzeba go od początku ustawiać.

      • jacek

        A ja to muszę go najpierw wyłączyć i wyłączyć, żeby działał…

  • Soemtron

    Zainstalowałem na Ubuntu 10.04 i większośc mam po angielsku :(

  • http://www.ubuntu-pomoc.org Szmitas

    Mam nadzieje, że wersja finalna będzie miała bardziej dopracowany tryb jednookienkowy, bo Gimp + Unity = totalna porażka.

    • EuGene

      Gimp rozwija się tak wolno, że po prostu nie nadąża za zmianami w systemie. Kiedy klecili obecną wersję (niestabilną wszak!, czyli nawet tego nie udało się dopiąć), to Ubuntu zmieniło się już kilka razy…

    • ubuntu-usr

      Wydaje mi się, że tuning w postaci dopasowania aplikacji do śrdowiska graficznego, leży w gestii twórców tegoś środowiska. Wyobraźmy sobie, że jest 100 popularnych środowisk i co? Każdy twórca aplikacji ma się skupiać nad integracją swego dzieła do każdego ze śrdodowisk?

      Myślę, że takie zabiegi powinny leżeć w gestii twórców wybranego śrdowiska. Z racji, że Canonical ma własne repo nie widzę przeszkód aby dopasowano GIMP-a po wydaniu wersji stabilnej. Wszak tak samo robi Novell w przypadku Libre Office i Open Suse.

      • EuGene

        Libre Office się dopasowuje? Jakoś ciężko im to idzie. Poza tym, gdyby developerzy środowiska mieli je modyfikować do każdego programu, który ktoś gdzieś popełni, to chyba nic innego by nie robili.

  • ubuntu-usr

    Częstotliwość wydań GIMP-a ma być szybsza po wydaniu wersji 2.8. W wersji 2.8 zajdzie wiele zmian, większość z nich w GIMP-ie nie będzie gołym okiem widoczna. Poza tym w tym roku GIMP dostał ze 4 jak nie 5 projektów w ramach Google Summer of Code, są to naprawdę wspaniałe projekty, niektórych Photoshop będzie mógł pozazdrościć. Myślę, że jak doczekamy się 2.8, to dalej będzie już z górki.

  • http://sinohyd.com hydraulic winch

    Mam nadzieje, że wersja finalna będzie miała bardziej dopracowany tryb jednookienkowy, bo Gimp + Unity = totalna porażka.

  • sru

    The upcoming v2.8 also introduces a huge amount of API deprecations and additions that have the potential to break existing 3rd party scripts and plug-ins.” To ja podziękuje.

  • mh

    Mi do szczęścia i pełni odejścia od Windowsa wystarczy gimp z trybem jedno okienkowym to dużo wygodniejsze, i ułatwia prace, po za tym Gimp 2.7.4 na Windowsa jest lepszy od Photoshopa jak dla mnie.

  • Ubuntownick

    Szanowni Państwo! Właśnie 11.10 dokonał częściowej aktualizacji dystrybucji i nie moge zainstalować gimpa/

    Oto błąd:
    Zależności dla następujących pakietów, nie zostały spełnione:

    gimp: Depends: python-gtk2 (>= 2.8.0) ale 2.24.0-2 zostanie zainstalowany
    Depends: libc6libc6 (>= 2.11) ale 2.13-20ubuntu5 zostanie zainstalowany
    Depends: libfontconfig1 (>= 2.8.0) ale 2.8.0-3ubuntu2 zostanie zainstalowany
    Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) ale 2.24.0-1ubuntu1 zostanie zainstalowany
    Depends: libglib2.0-0 (>= 2.31.2) ale 2.30.0-0ubuntu4 zostanie zainstalowany
    Depends: libgs9 (>= 8.61.dfsg.1) ale 9.04~dfsg-0ubuntu11.5 zostanie zainstalowany
    Depends: libgtk2.0-0 (>= 2.24.0) ale 2.24.6-0ubuntu5 zostanie zainstalowany
    Depends: libgudev-1.0-0 (>= 147) ale 1:173-0ubuntu4.1 zostanie zainstalowany xxx
    Depends: libjpeg62 (>= 6b1) ale 6b1-1ubuntu2 zostanie zainstalowany
    Depends: librsvg2-2 (>= 2.14.4) ale 2.34.1-2 zostanie zainstalowany
    Depends: zlib1g (>= 1:1.1.4) ale 1:1.2.3.4.dfsg-3ubuntu3 zostanie zainstalowany

  • Ja

    Mam pewien problem na ubuntu 11.10.
    Podczas aktualizacji gimp 2.7.3 zmienił wersję na 7.5, z tym, że nie chodził, ponieważ brakowało bibliotek,itd. … ogólnie masakra. Postanowiłem odinstalować gimp i tymczasowo wrzucić na koma 6.11. Jednak wolałbym mieć jakąś wersje 7. Repo (wyżej) instaluje mi wersje 7.5, z którą mam problemy.
    Czy jest jakiś sposób zainstalowania gimpa wcześniejszego (no chociażby 7.3) z repo? Za wszelką cenę wolałbym uniknąć kompilacji …

  • Ola

    Mam ten sam problem.
    „Następujące pakiety mają niespełnione zależności:
    gimp : Wymaga: libgimp2.0 (>= 2.7.5) ale nie zostanie zainstalowany
    Wymaga: libgimp2.0 (= 0.1.3-2) ale nie zostanie zainstalowany
    Wymaga: libglib2.0-0 (>= 2.31.2) ale 2.30.0-0ubuntu4 ma zostać zainstalowany
    E: Nie udało się naprawić problemów, zatrzymano pakiety z niespełnionymi zależnościami.”

    Dodam, że mam Kubuntu 11.10