Generowanie pliku xorg.conf w Ubuntu 9.10 i nowszym

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Plik xorg.conf domyślnie nie istnieje w Ubuntu 9.10 i nowszym, ponieważ w większości przypadków nie jest on wymagany do poprawnego działania systemu. Jednak w niektórych przypadkach (gdy korzystamy z wolnych sterowników), plik ten będzie potrzebny, dlatego przedstawię poniżej sposób na jego generację.

Przejdź do trybu tekstowego CTRL+ALT+F1 i zaloguj się tak, jakbyś logował się do systemu.

Wpisuj kolejno polecenia:

sudo su
cd /root
/etc/init.d/gdm stop
X -configure
rm /etc/X11/xorg.conf
mv /root/xorg.conf.new /etc/X11/xorg.conf
exit
startx

Gotowe, plik powinien być już wygenerowany. Aby sprawdzić czy faktycznie tak się stało, wydaj polecenie:

sudo gedit /etc/X11/xorg.conf

Efekt:

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
	Option	    "Xinerama" "off"
EndSection

Section "InputDevice"
	Identifier  "Synaptics Touchpad"
	Driver      "synaptics"
	Option	    "SendCoreEvents" "true"
	Option	    "Device" "/dev/psaux"
	Option	    "Protocol" "auto-dev"
	Option	    "HorizEdgeScroll" "0"
	Option	    "SHMConfig" "true"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • end192

    mam taki problem, to co tutaj zostalo zaprezentowane, nie działa u mnie na Ubu 10.04. Gdy wyłącze gdm i odpali mi sie czarny ekran od X-ow wpisuje podane polecenia, ale nic nie działa. Help ;)

  • http://www.ubuntu-pomoc.org Szmitas

    Zamiast

    X -configure

    spróbuj

    Xorg -configure
  • end192

    problem jest taki, że u mnie nawet polecenie startx nie działa. Wydaje mi sie że coś jest nie tak z tym czarnym ekranem, bo i mam czcionki jakies takie duze i po rozjeżdżane ;/

  • http://www.ubuntu-pomoc.org Szmitas

    A jakieś komunikaty masz po tych poleceniach?

  • end192

    zadnych komunikatow (zero reakcji)

  • http://www.ubuntu-pomoc.org Szmitas

    To zamiast:

    startx

    wpisz:

    sudo /etc/init.d/gdm start
  • end192

    wlasnie o to chodzi ze imi tam nic nie dziala (nie wiem co jest) jedyne co skutkuje jakim kolwiek efektem to kombinacja ctrl+alt+del co powoduje restart komputera, a tak to nic nie dziala. A wszystkie problemy zaczely sie jak zainstalowalem kde, ktore pozniej chcialem usunac, ale resztki zostaly. Np. gdy uruchamiam zamiast ekranu powitalnego ubuntu jest kubuntu, i jak wyłączam system to jakies „krzaki” sie pojawiaja. No i co najciekawsze komenda sudo shutdown 0 zamiast wylaczyc komputer zawiesza go na ekranie zamykania ;/

  • http://www.ubuntu-pomoc.org Szmitas

    Aby pozbyć się KDE spróbuj tego:

    aptitude search ~skde | egrep "^i" | awk '{ if($2 ~/A/){ print $3} else print $2}'

    Możesz wszystko zapisać do pliku tekstowego i z pliku usuwać, bądź od razu przekierować to jako argument apt-get remove.

    Mam nadzieję, że pomoże, daj znać.

  • end192

    usuwanie resztek kde sie powiodlo, ale nadal po wpisaniu komendy
    /etc/init.d/gdm stop
    nie mam zadnego wplywu na system, teksty sa porozjezdzane i jedyne co dziala to restart kompa za pomoca ctrl+alt+del ;/

  • http://www.ubuntu-pomoc.org Szmitas

    Szczerze mówiąc, nie mam pomysłu na rozwiązanie Twojego problemu.

  • http://www.zakladobrobki.pl/ Jaack

    Dobra, od nowa:
    – CTRL+ALT+F1
    – loguj się jako root,
    – stopujesz gdm (tu już masz coś nie tak? co dokładnie widzisz).

  • end192

    gdy zastopuje gdm pojawia mi sie czarny ekran z porozjezdzanymi tekstami odnosnie bootowania roznych elementow systemu ( po prawej znajduja sie takie [OK] ) i miga sobie kursor, gdy cos wpisuje to sie pojawia to co chce napisac, ale nie daje to zadnych efektow (cos w stylu jakbym pisal w pliku tekstowym, tam tez sie nic nie dzieje oprócz pojawiania się znaków).

  • http://www.zakladobrobki.pl/ Jaack

    To widocznie masz widok tty7, jeszcze raz wciśnij kombinację klawiszy:
    CTRL+ALT+1 a jak będzie ten sam widok, to spróbuj z 2, pod 7 jest środowisko graficzne zazwyczaj.
    I na wszystkich oprócz 7 powinneś mieć ładne pytanie o login ;)

  • end192

    o, dzięki wielkie i teraz znowu mam problem :) w pytaniu o login podaje mu i pyta sie o haslo i tez mu podaje, a on mi mowi ze zly login podalem (a wiem co mam za login :D )

  • http://www.zakladobrobki.pl/ Jaack

    jesteś pewien? myślę, że system do głupich nie należy i wie jakich ma użytkowników ;p
    jako użytkownik wpisz root i daj jego hasło (mam nadzieję Tobie znane).

  • end192

    do właśnie ja linuxa uważam za bardzo inteligentny system, ale żadne hasło i login nie działa (czy dam roota lub zwykłego uzytkownika zawsze jest to samo, czyli nic ) ;)

  • http://www.zakladobrobki.pl/ Jaack

    Jeszcze raz kolego.
    Uruchamiasz komputer, tak jak zawsze, logujesz się do systemu ładnie tak jak byś chciał wejść na neta czy cokolwiek.

    Następnie wciskasz na raz przyciski ALT, CTRL, 2.
    Ekran robi się czarny, u góry wyświetla się prośba o login, więc:
    – wpisujesz login ten co zwykle (np. ja wpisuję jaack), wciskasz enter.
    – system prosi o hasło, wpisuję np. jacekplacek (system nie pokazuje, że cokolwiek wpisujesz, nawet słynnych gwiazdek, bo świadomie to ukrywa (np. przed osobami które przez Twoje ramię mogłyby podpatrywać)), więc WPISUJESZ HASŁO DOKŁADNIE, OSTROŻNIE, POWOLI żeby mieć pewność że nie walnąłeś literówy!
    I super, udało Ci się zalogować, chyba, że nie znasz własnego hasła, albo nie wiesz co to CAPS LOCK ;p

  • Kamikulka

    Witam!

    Ubuntu 11.0 zainstalowałem dzisiaj i jestem raczej w Linux’ach zielony. Mam problem jak wielu z rozdzielczością. Moja grafika to SiS 761 i nie mam do niej sterowników. Ubuntu normalnie zainstalowało mi grafikę (przynajmniej tak było na początku) i mogłem zmieniać rozdzielczości do maks 19XX x 12XX ( nie pamiętam dokładnie). Potem system zalecił aktualizacje jakiś pakietów i aktualizowałem wszystko co kazał, potem restart kompa. Po restarcie rozdzielczość wskoczyła mi na 800X600. Szukałem dużo na necie i znalazłem wreszcie, ze to najprawdopodobniej xorg.conf którego nie miałem po aktualizacji. Za którymś razem trafiłem wreszcie na Waszą stronkę i robiłem wszystko tak jak kazaliście. Za drugim razem udało mi się stworzyć ten plik i było wszystko super. Potem chciałem sobie stworzyć nowego użytkownika i stworzyłem, potem reset kompa. Jak włączyłem ubuntu to xorg.conf nie było już ani na jednym i drugim koncie. Po wielu próbach wreszcie się wkurzyłem i usunąłem konto drugie i zostawiłem to domyślne. I teraz zanic w świecie nie mogę stworzyć tego pliku, a jak już mi się udaje to i tak nic z tego bo dalej nie mogę zwiększyć rozdzielczości. Pomocy!

    Poszukam jeszcze może jakiś sterowników do mojej karty i może to coś pomoże. Karta jest zintegrowana. A i zatrzymuje się po wpisaniu polecenia X -configure (albo Xorg -configure), przewija mi tam całą listę czegoś, a na końcu jest Configuration failed. Co może być?

  • Pingback: News [12.10] Fontconfig warning: „/etc/fonts/conf.d/50-user.conf”, line 9: reading configurations from ~/.fonts.conf is deprecated.()

  • Pingback: News [Kubuntu 12.10] Fontconfig warning: „/etc/fonts/conf.d/50-user.conf”, line 9: reading configurations from ~/.fonts.conf is deprecated.()

  • gosc

    U mnie nie ma gdm