DockBarX jako aplet w Mate

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!
Jest to artykuł nadesłany do nas przez Czytelnika o ksywce jeremi360 – dziękujemy kolejny raz!

Pewnie część z Was zna DockBarX – jest to prosty dock mający sporo ciekawych funkcji (np. zarządzanie odtwarzaczmi muzyki i wideo, czy korzystanie z quicklist z Unity (nie trzeba instalować Unity)).
Na stronie projektu jest wersja dla Mate, ale w formie źródła i to niestety nie dającego się skompilować. Na szczęście ostatnio przeglądając Internet natrafiłem na prostą do ściągniecia paczkę DEB.
Instalujemy wydjąc następujące polecenia:

sudo apt-add-repository ppa:nilarimogard/webupd8
sudo apt-get update && apt-get install -y dockbarx dockbarx-themes-extra

Następnie pobieramy paczkę DEB ze strony www.download.ubuntu-pomoc.org/dockbarx-mate_0.48-1_all.deb.

Instalujemy pobraną paczkę DEV, wydając następujące polecenia:

cd /miejsce/gdzie/pobrałeś/paczkę
sudo dpkg -i dockbarx-mate*.deb

Następnie zabijamy panel:

killall mate-panel

Po tym jak panel uruchomi się ponownie dodajemy do niego applet ”DockBarX Applet” i gotowe.

Poniżej działające rozwiąznie u mnie:

DockBarX jako aplet w Mate

Efekt końcowy

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • macios4x

    Mam MATE 1.4 świeżo po instalacji, doinstalowałem MateNu ale wywala błąd przy dodawaniu do panelu:

    Napotkano problem podczas wczytywania „OAFIID:MATE_MateNu”.
    Usunąć aplet z konfiguracji?

    Nie pomaga polecenie killall mate-panel a kompilacja przebiegła pomyślnie i wszystkie zależności mam przecież spełnione.

    • jeremi360

      Mam też mam mate 1.4 i chodzi bez problemów
      Ale nigdy nie instalowałem ani niesłyszałem o MateNu pradopodobnie pozostały ponim jeszcze jakieś śmiecie proponuję od instlować wszystkie pakiety mate i matenu az pomocą: sudo apt-get purge nazwy pakietów po spacjach. I zainstalować z powrotem mate.

    • eMcE

      To jest znany błąd jeszcze z czasów GnoMenu i niestety ciągnie się za jego forkiem Mate Nu.
      Jeśli masz Mate, nie instalujesz „dockbarx”, bo się popierniczą paczki.
      Instalujesz tylko „dockbarx-mate” i ewentualnie paczkę z themami.
      sudo add-apt-repository ppa:dockbar-main/ppa
      sudo apt-get update
      sudo apt-get install dockbarx-mate
      killall mate-panel

      Do tego doinstaluj sobie paczki:
      python
      python-numpy
      python-mate
      Restart kompa i powinno ruszyć.

  • Art

    …a tak przy okazji: nie „od instalować” i „Po niżej” tylko łącznie: odinstalować i poniżej. Czy Wam już edytory nie podkreślają błędów?
    A potem się słyszy, że Linuks jest robiony przez amatorów, laików i niedouczonych pryszczatych smarkaczy…

    • http://www.ubuntu-pomoc.org Łukasz Schmidtke

      Dzięki, a tak przy okazji: niby dlaczego edytor miał podkreślić te błędy?

      • Art

        …a może trzeba czasem zadbać, żeby to robił? Nie lepiej zrobić coś porządnie?

        • http://www.ubuntu-pomoc.org Łukasz Schmidtke

          Liczę na instrukcję.

          • Art

            …w zaawansowanych ustawieniach przeglądarki np. chromium włącz sprawdzanie pisowni w j. polskim. Po instalacji zwykle ta funkcja działa domyślnie w wielu przeglądarkach i niczego nie trzeba ustawiać. Wyraz napisany z błędem jest podkreślony czerwonym wężykiem.

            W dzisiejszych czasach, żeby pisać z błędami, trzeba być zwykłą fleją.

  • http://www.ubuntu-pomoc.org Łukasz Schmidtke

    @Art: i uważasz, że błędy typu: „po niżej” oraz „od instalować” zostaną wykryte? Pomyśl, bo widzę, że od kilku godzin nie rozumiesz o co chodzi…

    • Art

      …masz rację. Edytory nie wykrywają takich błędów. Tego się trzeba nauczyć.
      Mea culpa.

      Tak w ogóle, za dużo wymagam od ludzi, kształconych przez przymusowy, „darmowy” system edukacji publicznej, finansowany pod przymusem z kieszeni podatnika i dlatego schodzący coraz bardziej „na psy”. Przepraszam.

      • jeremi360

        edytor i tak by mi nic nie podkreśli bo mi firefox pomimo prawidłowych ustawień podkreślał, tylko błędy angielskich słowach

  • McCzayaPL

    Grunt Art że mamy takich miodków jak ty którzy będą nas poprawiać i uczyć o poprawnej polszczyźnie.

    Czepiasz się poprawności polszczyzny używanej przez forumowiczów a sam zasuwasz z łaciną Mea culpa. a nie można po polskiemu ?? moja wina xD czy to nie ładniej brzmi ?