Błąd „Broken pipe” przy instalacji Skype 4.0

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Jak wiadomo kilka dni temu wydano Skype 4.0 na Linuxa. Niektórzy użytkownicy Ubuntu skarżą się na problemy przy instalacji objawiający się takim komunikatem na końcu logu:

dpkg-deb (subprocess): failed in write on buffer copy for failed to write to pipe in copy: Broken pipe

Można to łatwo naprawić, wystarczy przed instalacją usunąć poprzednią wersję poleceniem:

sudo apt-get remove skype skype-bin

Teraz można zainstalować paczkę deb Skype (można pobrać stąd) dwuklikiem lub tym poleceniem:

sudo dpkg -i /ścieżka/do/paczki.deb
Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • Soemtron

    U mnie też na wersji 64-bitowej brakowało bibliotek i zainstalowałem sudo apt-get install lib32stdc++6 lib32asound2 lib32gcc1.Potem instalacja Skypa poszła bez problemu.

  • fioletowyb

    zamiast „sudo dkpg…” powinno być „sudo dpkg…” :D mała literówka, ale nowicjuszom może zaszkodzić ;-)

    • Admc

      Poprawiłem, tak to jest kiedy się pisze artykuły w nocy :D

  • ARNi

    sudo add-apt-repository ppa:skype-wrapper/ppa
    sudo apt-get update && sudo apt-get install skype-wrapper

    opis : http://goo.gl/32xiv

    • Admc

      Warto wspomnieć że skype-wrapper jest tylko dla użytkowników Unity.

  • emeritus

    Ciekawe jak będzie z moją kamerką.Od kilku wydań Ubuntu moja kamerka działa wyłącznie z preloadem wpisanym w aktywator.Boję się zainstalować tego nowego Skype’a bo teraz może i to nie pomóc.Ano zobaczymy.Na dokładkę musiałem wrócić z 12.04 do 11.10 bo z każdą aktualizacją było coraz gorzej.Parę razy dziennie wyskakiwał mi komunikat o błędzie a w końcu grafika zaczęła mi się wieszać i musiałem co trochę się wylogować i zalogować ponownie,ciekawe bo zaraz po zainstalowaniu chodziło wszystko jak burza..Do bani z takim LTS-em,zainstalowałem 11.10 i wszystko śmiga.

    • Admc

      Skype 4.0 ponoć obsługuje więcej kamer niż 2.2. Poza tym warto kupować sprzęt który jest zgodny z Ubuntu, wtedy unikniesz problemów.

      https://wiki.ubuntu.com/SkypeWebCams

      Ja kilka dni temu kupiłem kamerkę Logitech C310 bo jest na liście i wszystko działa :)

      • emeritus

        Oczywiście jakiś czas temu kupiłem moją kamerkę kierując się opiniami w best4linux i działała.Ale po instalacji kolejnego Ubuntu przestała.I do tej pory bez wpisania któregoś z poleceń z preloadem w aktywator nie pójdzie.Ale oczywiście zaryzykuję,najwyżej kupię sobie tego Logitecha C310:-)

        • Admc

          Najlepiej kupić kamerę która korzysta z technologii UVC (zgodna z Windows Vista). Wtedy będziesz miał pewność że będzie działać zawsze, ponieważ UVC jest dobrze zaimplementowanym standardem.

          http://en.wikipedia.org/wiki/USB_video_device_class
          http://www.ideasonboard.org/uvc/

          • emeritus

            Dzięki!Zawsze można liczyć na linuksową społeczność.Ale zainstalowałem tego nowego Skype’a i moja stara kamerka A4tech działa od strzału,bez kombinowania z poleceniami w aktywatorze.