Automatyczne montowanie partycji NTFS

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Wiele osób (spośród posiadaczy Ubuntu) jest równocześnie użytkownikiem Windowsa. Zdarza się, że dla zaoszczędzenia miejsca posiadają wydzielone partycje NTFS, na których magazynują takie dane jak muzyka, zdjęcia. System Ubuntu gwarantuje do nich dostęp, jednak standardowo taka partycja nie jest automatycznie montowana i przed wejściem na nią trzeba podać hasło. W tym artykule zaprezentuję sposób na automatyczne montowanie partycji od razu po starcie systemu.

Na początek zainstaluj pakiet, dzięki któremu Twój system będzie mógł obsługiwać partycje NTFS:

sudo apt-get install ntfs-3g

Teraz musisz sprawdzić jaki „numerek” przypisał system dyskom, które chcesz zamontować. Otwórz terminal i wydaj polecenie:

sudo fdisk -l

To polecenie wyświetli wszystkie wykrywane przez system partycje. Powinna zainteresować Cię ta część:

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         898     7213153+   7  HPFS/NTFS
/dev/sda2             899       19456   149067135    f  W95 Ext'd (LBA)
/dev/sda5            8188       19456    90518211    7  HPFS/NTFS
/dev/sda6             899        1022      995967   82  Linux swap / Solaris
/dev/sda7            1023        8187    57552831   83  Linux

Łatwo z niej wywnioskować, że partycje NTFS posiadają oznaczenie sda1 i sda5 – oczywiście w Twoim przypadku mogą być to zupełnie inne oznaczenia.

Nie zamykając terminalu wydaj polecenie:

sudo ls -l /dev/disk/by-uuid/

Tym razem powinieneś zainteresować się tym:

lrwxrwxrwx 1 root root 10 2008-08-08 09:51 343e5ec1-99ed-4682-a6cb-5aa6a8e1f44a -> ../../sda7
lrwxrwxrwx 1 root root 10 2008-08-08 09:51 92701CA6701C9359 -> ../../sda5
lrwxrwxrwx 1 root root 10 2008-08-08 09:51 A080692280690060 -> ../../sda1
lrwxrwxrwx 1 root root 10 2008-08-08 09:51 bb2b23d0-b133-4ca7-b0cb-fc8aa44b32f7 -> ../../sda6

Odszukaj na liście partycje, które chcesz zamontować (w MOIM przypadku sda5 i sda1) i zapisz sobie ich UUID (specjalnie je pogrubiłem)

Aby poprawnie zamontować partycję musisz utworzyć katalog, do którego dana partycja będzie montowana. Aby to zrobić wydaj w terminalu polecenie:

sudo mkdir /media/nazwa_katalogu

Polecam tworzenie katalogów o nazwie odpowiadającej oznaczeniu naszego dysku, czyli dla sda1 będzie to:

sudo mkdir /media/sda1

a dla sda5:

sudo mkdir /media/sda5

Podana ścieżka będzie ważna w dalszej części poradnika! Zapamiętaj ją!

Teraz będzie z górki, jednak nadal musisz być ostrożny. Czas na edycję pliku fstab, aby to zrobić wpisz:

sudo gedit /etc/fstab

Zobaczysz coś takiego:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda7
UUID=343e5ec1-99ed-4682-a6cb-5aa6a8e1f44a /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda6
UUID=bb2b23d0-b133-4ca7-b0cb-fc8aa44b32f7 none            swap    sw              0       0
/dev/sda5    /media/sda5    ntfs    rw,nosuid,nodev,noatime,user_id=0,group_id=0,allow_other,auto    0    1
/dev/sda1    /media/sda1    ntfs    rw,nosuid,nodev,noatime,user_id=0,group_id=0,allow_other,auto    0    1
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Odszukaj partycje które chcesz zamontować i je usuń (Ctrl + X) – cały wpis, tak jak zaznaczyłem. Nie zamykaj pliku!

Teraz uzupełnij odpowiednio poniższy przykład:

#/dev/oznaczenie_partycji
UUID=uuid_partycji /media/nazwa_katalogu ntfs defaults,utf8,umask=007,gid=46 0 0

Pogrubione miejsca musisz odpowiednio uzupełnić. I tak, dla partycji sda1 będzie to wyglądać nasŧępująco:

#/dev/sda1
UUID=A080692280690060 /media/sda1 ntfs defaults,utf8,umask=007,gid=46 0 0

0 na końcu zonacza, że nie chcę, aby dostęp do partycji był zabezpieczony hasłemaby zabezpieczyć ustaw 1

A dla sda5:

#/dev/sda5
UUID=92701CA6701C9359 /media/sda5 ntfs defaults,utf8,umask=007,gid=46 0 0

Ostatecznie uzyskaliśmy takie dwa wpisy:

#/dev/sda1
UUID=A080692280690060 /media/sda1 ntfs defaults,utf8,umask=007,gid=46 0 0
#/dev/sda5
UUID=92701CA6701C9359 /media/sda5 ntfs defaults,utf8,umask=007,gid=46 0 0

Musisz je teraz umieścić w pliku fstab. Przejdź do okna edycji tego pliku i dodaj te wpisy na końcu. Ostatecznie Twój plik fstab powinien wyglądać podobnie do tego:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda7
UUID=343e5ec1-99ed-4682-a6cb-5aa6a8e1f44a /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda6
UUID=bb2b23d0-b133-4ca7-b0cb-fc8aa44b32f7 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
#/dev/sda5
UUID=92701CA6701C9359 /media/Pliki ntfs defaults,utf8,umask=007,gid=46 0 0
#/dev/sda1
UUID=A080692280690060  /media/System ntfs defaults,utf8,umask=007,gid=46 0 0

Zapisz plik (Ctrl + S) i uruchom ponownie komputer. Po restarcie na pulpicie powinny pokazać się zamontowane ikony partycji, do których teraz masz swobodny dostęp.

Co robić jeśli powyższy sposób nie pomógł?

1. Na początek spróbuj zamontować partycję ręcznie:

sudo mount -t ntfs-3g /dev/sdaX /media/sdaX

gdzie sdaX to numer partycji, a /media/sdaX to katalog w którym chcesz zamontować partycję.

2. Jeśli dostałeś podobną informację do tej:

$LogFile indicates unclean shutdown (0, 0) Failed to mount '/dev/sdaX': Operation not supported Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sdaX /media/sdaX -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sdaX /media/sdaX ntfs-3g force 0 0

Wydaj w terminalu polecenie:

sudo mount -t ntfs-3g /dev/sdaX /media/sdaX -o force

I sprawdź czy partycja została zamontowana.

3. Teraz dodaj do /etc/fstab wpis, który będzie automatycznie montował partycję przy starcie systemu:

sudo gedit /etc/fstab

i dodaj wpis:

/dev/sdaX /media/sdaX ntfs-3g force 0 0

gdzie /dev/sdaX to numer partycji, a /media/sdaX to katalog, w którym będzie montowana partycja. Zapisz plik (Ctrl + S) i uruchom ponownie komputer, aby zobaczyć rezultaty.

Partycja się montuje, jednak nie masz prawa zapisu?

1. Otwórz terminal i zainstaluj dwa pakiety:

sudo apt-get install ntfs-3g ntfs-config

2. Po zakończonej instalacji wydaj polecenie:

gksu ntfs-config

3. W oknie, które Ci się pojawi zaznacz obie opcje i zapisz zmiany. Uruchom ponownie komputer.

Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • Orzech

    Stary, masz u mnie mistrza, wszystko hula jak powinno. Wielkie dzieki, bardzo pomogles. Browar dla Ciebie!!! Pozdro! :]

  • marley1987

    drugi sposb odrazu zadzialal dzieki

  • http://m1gu3l.pl/blog m1gu3l

    $LogFile indicates unclean shutdown (0, 0) Failed to mount ‚/dev/sdaX’: Operation not supported Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the ‚Safely Remove Hardware’ icon in the Windows
    taskbar then shutdown Windows cleanly.

    ^ u mnie force nie pomogl, dopiero >kilkakrotne< powtorzenie tego

  • http://ubuntu-pomoc.org Szmitas

    Napisane jest, że „X” musisz zastąpić odpowiednim numerem partycji :)

    Z tego co widzę nie zastosowałeś się do tego polecenia, dlatego nie było żadnego efektu.

    Pozdrawiam.

  • milman

    a mi gówno działa !
    już „na początku” mam problemy : sudo apt-get install ntfs-3g
    wyskoczyło mi:

    E: Nie udało się uzyskać blokady /var/lib/dpkg/lock – open (11 Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

  • milman

    i Szmitas na dodatek ja nie napisałem X tylko 1 lub 5 i mam to samo !

  • http://ubuntu-pomoc.org Szmitas

    @Milman: gdybyś poszukał na tej stronie informacji na temat blokady /var/lib/dpkq/lock dowiedziałbyś się, że jest to związane z tym, że masz otwarty jednocześnie Menedżer Pakietów Synaptic i terminal, w którym instalujesz dodatkowe paczki. Zamknij Synaptica i wydaj polecenie ponownie.

    A co do drugiego komentarza – masz to samo co m1gu3l, tak? Może po prostu nie utworzyłeś katalogu, do którego ma być montowana partycja, dlatego system protestuje? Aby stworzyć katalog, do którego będzie montowana partycja wydaj w terminalu polecenie: sudo mkdir /media/sdaX, gdzie X to numer partycji.

    Pozdrawiam.

  • milman

    ok, mam takie coś :

    milman@milman:~$ sudo ls -l /dev/disk/by-uuid/
    razem 0
    lrwxrwxrwx 1 root root 10 2008-11-30 21:56 86b5f805-25e6-4a19-a7b1-3138d694463b -> ../../sda6
    lrwxrwxrwx 1 root root 10 2008-11-30 21:56 88DCD3F3DCD3DA10 -> ../../sda5
    lrwxrwxrwx 1 root root 10 2008-11-30 21:56 C28C94968C948697 -> ../../sda1

    wpisuje:
    milman@milman:~$ sudo mkdir /media/sda1
    wyskakuje:
    mkdir: nie można utworzyć katalogu `/media/sda1′: File exists

    co jest nie tak ?

    • alus992

      Zatrzymałem się na tym samym momencie momencie, a to co czytam dalej w ogóle mi nie pomaga bo się gubię w tym…(Linuksa używam po raz pierwszy, właśnie minęła 3 godzina użytkowania- Ubuntu 11.04):
      Urządzenie Rozruch Początek Koniec Bloków ID System
      /dev/sda1 1 1959 15728640 27 Nieznany
      /dev/sda2 * 1959 1972 102400 7 HPFS/NTFS
      /dev/sda3 1972 21385 155940864 7 HPFS/NTFS
      /dev/sda4 21385 60802 316612608 7 HPFS/NTFS
      alus992@ubuntu:~$ sudo ls -l /dev/disk/by-uuid/
      razem 0
      lrwxrwxrwx 1 root root 10 2011-04-29 23:49 7E74ED8474ED3F8F -> ../../sda4
      lrwxrwxrwx 1 root root 11 2011-04-29 23:49 8da1724f-61f3-4f62-a2c9-5fdd56eefb9f -> ../../loop0
      lrwxrwxrwx 1 root root 10 2011-04-29 23:49 ACC8BF90C8BF5774 -> ../../sda3
      lrwxrwxrwx 1 root root 10 2011-04-29 23:49 E664BCDC64BCB123 -> ../../sda1
      lrwxrwxrwx 1 root root 10 2011-04-29 23:49 F646BDA646BD684F -> ../../sda2
      alus992@ubuntu:~$ sudo mkdir /media/sda4
      mkdir: nie można utworzyć katalogu `/media/sda4′: Plik istnieje
      ———————————–
      po komendzie : alus992@ubuntu:~$ cd /media && ls
      wyskakuje mi : ACC8BF90C8BF5774 sda3 sda4 SYSTEM
      ————————————

      Po pierwszej liście wszystkich dysków ntfs domyślam się że tego co nie widzę w „Miejsca” to sda4 (bo widzę że ma taką samą wielkość jak mój dysk D w Win7, ponieważ sda3 widzę (mój dysk C w win7) no i System też widzę bo ma 100mb,czyli sda2.

      Pomocy…

      • alus992

        Zapomniałem a to po komendzie sudo gedit /etc/fstab : # /etc/fstab: static file system information.
        #
        # Use ‚blkid -o value -s UUID’ to print the universally unique identifier
        # for a device; this may be used with UUID= as a more robust way to name
        # devices that works even if disks are added and removed. See fstab(5).
        #
        #
        proc /proc proc nodev,noexec,nosuid 0 0
        /host/ubuntu/disks/root.disk / ext4 loop,errors=remount-ro 0 1
        /host/ubuntu/disks/swap.disk none swap loop,sw 0 0

        • Szmitas

          Do pliku /etc/fstab dodaj poniższe linijki:

          #/dev/sda3
          UUID=ACC8BF90C8BF5774 /media/sda3 ntfs defaults,utf8,umask=007,gid=46 0 0
          #/dev/sda4
          UUID=7E74ED8474ED3F8F /media/sda4 ntfs defaults,utf8,umask=007,gid=46 0 0

          Zapisz plik (CTRL + S) i uruchom ponownie system.

          • alus992

            Nie mogę nic dopisać, cały czas plik jest nie możliwy do edycji tylko mogę skopiować to co w nim się znajduje:/

          • Szmitas

            W jaki sposób edytujesz plik /etc/fstab?

  • http://ubuntu-pomoc.org Szmitas

    „File exists” taki katalog już istnieje, czyli to nie jest wina braku katalogu.

    hmmm…

    Co się dzieje jak do fstaba dodasz taki wpis: (i uruchomisz ponownie komputer):
    #/dev/sda1
    UUID=C28C94968C948697 /media/sda1 ntfs defaults,utf8,umask=007,gid=46 0 0

    • alus992

      Udało mi się edytować, ale po restarcie pokazała mi się informacja, że nie można zamontować dysku sda4 (…). Przy uruchamianiu nacisnąłem „S” by pominąć montowanie. Nic na razie nie zmieniłem w tym pliku (zostawiłem to co kazałeś dopisać). Dodam, że w „Miejsca” znalazłem zawartość dysku mojego D (czyli sda4) w katalogu Komputer/System plików/host. Dodam ze zainstalowałem Ubuntu na dysku D, na którym miałem dwa foldery „Program Files” i „Vuze Pobrane”
      Dysk C wyświetla mi się w „Komputer” jako „Dysk Samsung o łącznej pamięci 160gb” po wejściu w niego na pasku mam nazwę „sda3”

  • milman

    pisz po ludzku :D
    krok po kroku jestem kompletnie zielony… uczę się linuxa :)

  • http://ubuntu-pomoc.org Szmitas

    Dobrze, od początku. Wpisz kolejno w terminalu:

    sudo ls -l /dev/disk/by-uuid/ – wklej rezultat i powiedz, które partycje chcesz zamontować.

    sudo gedit /etc/fstab – pokaż jego zawartość.

    cd /media && ls – pokaż co kryje to polecenie.

    Wklej wszystkie wyniki czytelnie – zaoszczędzi mi to czasu.

  • milman

    lrwxrwxrwx 1 root root 10 2008-11-30 21:56 86b5f805-25e6-4a19-a7b1-3138d694463b -> ../../sda6
    lrwxrwxrwx 1 root root 10 2008-11-30 21:56 88DCD3F3DCD3DA10 -> ../../sda5
    lrwxrwxrwx 1 root root 10 2008-11-30 21:56 C28C94968C948697 -> ../../sda1

    sda1 i sda5
    —————————————
    # /etc/fstab: static file system information.
    #
    #
    proc /proc proc defaults 0 0
    # /dev/sda6
    UUID=86b5f805-25e6-4a19-a7b1-3138d694463b / ext2 defaults,errors=remount-ro 0 1
    # /dev/sda1
    UUID=C28C94968C948697 /media/sda1 ntfs defaults,umask=007,gid=46 0 1
    # /dev/sda5
    UUID=88DCD3F3DCD3DA10 /media/sda5 ntfs defaults,umask=007,gid=46 0 1
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0

    ————————————————————————————–

    cdrom cdrom0 floppy floppy0 sda1 sda5 sda6

  • http://ubuntu-pomoc.org Szmitas

    Wpis wygląda na poprawny. Mimo to nie masz dostępu do partycji? Jaki dokładnie dostajesz komunikat przy próbie otworzenia ich?

    Zainstalowałeś ntfs-3g?

  • milman

    tak zainstalowałem
    wszystko przeszło bez przeszkód.
    komunikat :

    Nie masz uprawnień do zamontowania woluminu ‚Dysk’

  • milman

    You are not supposed to show G_IO_ERROR_FAILED_HANDLED in the UI

    takie coś się jeszcze pokazało po czasie

  • http://ubuntu-pomoc.org Szmitas

    A próbowałeś ostatniej opcji opisanej w tym artykule? Tzn. „Partycja się montuje, jednak nie masz prawa zapisu?”

    To już musi pomóc :)

  • milman

    E: Nie udało się uzyskać blokady /var/lib/dpkg/lock – open (11 Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

  • http://ubuntu-pomoc.org Szmitas

    A co pisałem wcześniej? Zamknij Synaptica i instaluj tylko w terminalu.

  • milman

    wyskoczyła mi 2 informacja z podpunktu Co robić jeśli powyższy sposób nie pomógł?

  • milman

    nie martw się już :)
    jesteś boski, normalnie cię kocham jesteś obkuty jak nie wiem i mam dla ciebie propozycję…
    wystarczy że napiszesz do mnie na jonderko@spacja.org a dostaniesz posadę do Linuxa :) co ty na to ? ;D

  • http://ubuntu-pomoc.org Szmitas

    To problem rozwiązany czy nie? Bo już się zagubiłem…

  • milman

    Tak, wszystko w porządku. Jeżeli jesteś zainteresowany mam dla Ciebie miejsce w redakcji spacji. Napisz do mnie na @ : jonderko@spacja.org

  • Daw

    A dlaczego wpisywać jakieś UUID zamiast np. /dev/sd5?

    A zresztą zawsze mam ten komunikat o Windowsie i działa tylko ten force.

  • http://ubuntu-pomoc.org Szmitas

    UUID partycji są stałe. Ich nazwy mogą się zmienić.

  • PrzeMuS

    Super rada. Wszystko działa elegancko. Super czytelnie i zrozumiale opisane. Bardzo dziękuję i pozdrawiam

  • kamilmroz12

    mam problem z montowaniem partycji… Uzywam Xubuntu i gdy w konsoli wpisuje „sudo gedit /etc/fstab” wyskakuje mi komunikat ze nie ma takiego polecenia… Pomocy

  • http://ubuntu-pomoc.org Szmitas

    Użyj innego edytora tekstu np. nano:

    sudo nano /etc/fstab
  • kamilmroz12

    dziekuje Szmitas, pomoglo:) mam jeszcze jedno pytanie… a jak zamontowac partycje fat32 wystarczy zamiast ntfs w pliky fstab zamienic na fat32?

  • http://ubuntu-pomoc.org Szmitas

    Myślę, że powinno wystarczyć. Spróbuj i daj potem znać :)

  • kamilmroz12

    wpisanie fat32 nie pomoglo, ale przypomnialem sobie ze gdy mialem auroxa przy partycjach fat32 nalezalo wpisac „vfat” i teraz działa :)

  • desant

    Trochę odbiega to od tematu, ale pewnie będziesz wiedział. Niedawno podłączyłem sobie 2 dysk i jest on sformatowany jako ext3, w pliku /etc/fstab go niema, jak sprawić żeby był montowany automatycznie?

    Dysk jest wykrywany jako sda5 a w pliku etc/fstab jako sda5 jest cd-rom…

  • http://ubuntu-pomoc.org Szmitas

    Wklej wynik polecenia:

    sudo fdisk -l

    oraz

    sudo ls -l /dev/disk/by-uuid/

    PS: skoro dysk główny wykrywany jest jako sdA to drugi dysk powinien być jako sdB :)

    Pozdrawiam.

  • desant87

    Disk /dev/sda: 20.0 GB, 20020396032 bytes
    255 heads, 63 sectors/track, 2434 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00000001

    Device Boot Start End Blocks Id System
    /dev/sda2 1 2434 19551073+ 5 Extended
    /dev/sda5 1 2434 19551042 83 Linux

    Disk /dev/sdb: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xa849a849

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 18700 150207718+ 83 Linux
    /dev/sdb2 18701 19457 6080602+ 5 Extended
    /dev/sdb5 18701 19457 6080571 82 Linux swap / Solaris

    razem 0
    lrwxrwxrwx 1 root root 10 2009-04-12 22:18 01f7b2b3-10d6-4c35-a7d1-65ca9f50cd5b -> ../../sdb1
    lrwxrwxrwx 1 root root 10 2009-04-12 22:18 8048a1e2-b823-4b35-9cfd-b16da260c692 -> ../../sda5
    lrwxrwxrwx 1 root root 10 2009-04-12 22:18 e619739d-4b91-4d78-a915-f69da7100733 -> ../../sdb5

  • http://ubuntu-pomoc.org Szmitas

    Pokaż mi jeszcze swojego fstaba.

  • desant

    # /etc/fstab: static file system information.
    #
    #
    proc /proc proc defaults 0 0
    # /dev/sda1
    UUID=01f7b2b3-10d6-4c35-a7d1-65ca9f50cd5b / ext3 relatime,errors=remount-ro 0 1
    # /dev/sda5
    UUID=e619739d-4b91-4d78-a915-f69da7100733 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

  • http://ubuntu-pomoc.org Szmitas

    Utwórz katalog, do którego będziesz montował dysk:

    sudo mkdir /media/dysk

    I potem dodaj do fstaba:

    UUID=8048a1e2-b823-4b35-9cfd-b16da260c692 /media/dysk ext3 relatime,errors=remount-ro 0 1
  • nettmanek

    Działa pierwszy sposob na kubuntu 9.04

  • rafsiu

    wszystko ładnie pięknie tylko czy ktoś mi powie czy można zrobić aby nie były ikony wyświetlane na pulpicie są zupełnie niepotrzebne
    dostęp jest np z menu „MIEJSCA”
    Chodzi tylko o automontowanie aby programy mogly korzystać z zasobów a nie o powielanie skrótów

  • http://ubuntu-pomoc.org Szmitas

    Wystarczyło użyć wyszukiwarki zawartej na stronie, gdyż taki artykuł już się pojawił – klik

  • rafsiu

    dzięki Szmitas
    następnym razem postaram się być bardziej samodzielny
    poza tym zapamiętam sobie „gconf-editor” bo widzę że sporo tam jest

  • white_

    dzięki. fachowo i rzeczowo opisany sposób rozwiązania problemu, to lubię. pozdrawiam.

  • mru

    u mnie polecenie sudo gedit /etc/fstab nie spowodowało właściwie niczego;
    sudo nano etc/fstab otworzyło mi pusty dokument…
    to znaczy że nie mam tego pliky fstab w ogóle?
    co dalej?

  • mru

    na polecenie sudo mount -t ntfs-3g /dev/sdaX /media/sdaX -o force
    wyskakuje mi że mounting failed media/sda5 no file such on directory

  • http://ubuntu-pomoc.org Szmitas

    Widocznie korzystasz z innego środowiska graficznego niż GNOME (do którego przypisany jest edytor Gedit).
    Zwróć uwagę, że ścieżka wygląda tak: /etc/fstab, a nie etc/fstab – to znacząca różnica.
    Wydaj polecenie:

    sudo kate /etc/fstab

    lub

    sudo nano /etc/fstab

    Co do drugiego komentarza. Angielski się kłania – próbujesz zamontować partycję do katalogu, który nie istnieje.

  • mru

    racja, przeoczyłem pierwszy slash…
    teraz zadziałało
    dzięki za szybką odpowiedź
    P.S. nie wiem z jakiego środowiska korzystam – dziś pierwszy raz w życiu uruchomiłem linuxa

  • mru

    … ale w zakładce system mam pozycję ‚info o gnome’…
    natomiast /etc/fstab nie uruchamiało się nawet z tym slashem w gedit tylko w nano…

  • mru

    Wszystko zadziałało, ale nie od razu…
    Najpierw zadziałało tylko na partycję sda5, ale nie pokazała się na pulpicie przy starcie tylko po wejściu w nią przez miejsca wskoczyła na pulpit.
    Pozostałe partycje czyli sda6 i sda7 oraz te z sdb poszły dopiero przez force
    Teraz te, które zadziałały po force pokazują się na pulpicie przy starcie systemu, a sda5 nadal jest dostępna w miejscach, a na pulpit wpada po pirwszym uruchomieniu z miejsc.
    Najważniejsze, że działa.
    THX i wielki szacun dla Szmitasa za ten wątek – bez niego zniechęciłbym się w pierwszym dniu używania ubuntu i z niesmakiem wrócił do windy.

  • http://ubuntu-pomoc.org Szmitas

    To, że pojawia się na pulpicie dopiero po wejściu w nią oznacza, że nie jest automatycznie montowana po starcie systemu, więc w którymś miejscu musiałeś popełnić błąd.

    Pozdrawiam.

  • mru

    Dla mnie najważniejsze jest, że mam dostęp do wszystkich partycji, bo wcześniej nie mogłem żaadnej otworzyć nawet ręcznie. Miałem ciągle komunikat, że nie można zamontować partycji, albo, że nie mam do tego uprawnień.

  • Milad

    Dzięki ;)

  • Jarek

    Dzięki. Dobra instrukcja :)

  • Morghull

    Szacun dla Ciebie, poszlo za pierwszym razem (moj XBMC) smiga jak nalezy [na oddzielnych dyskach ntfs mam filmy]

  • khorneeq

    Super pomoc, wszystko napisane kroko po kroku, czyli tak jak w poradniku być powinno.
    Przepis działa również dla dysków w systemie FAT32, z czego jestem niezmiernie szczęśliwy :)

  • Dominika

    Pomocy!Zatrzymałam się na etapie fstab i nie wiem co dalej ;/ Po wywołaniu okna fstab pojawiło mi się coś takiego:
    # /etc/fstab: static file system information.
    #
    # Use ‚blkid -o value -s UUID’ to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    #
    proc /proc proc defaults 0 0
    # / was on /dev/sda3 during installation
    UUID=29c633be-7f62-487e-a2b5-f08fb728a08e / ext3 errors=remount-ro 0 1
    # swap was on /dev/sda4 during installation
    UUID=964116ac-ad4f-45d9-8161-738aac2f889a none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

    moje dyski ntfs to sda1 i sda2,ale nie ma ich w tym komunikacie. W ogóle różni się on od tego zamieszczonego przez Ciebie. Co mam zrobić?

  • http://www.ubuntu-pomoc.org Szmitas

    Skoro nie masz tych wpisów, to nie masz co usuwać i wystarczy przejść do następnego kroku. Powodzenia :)

  • Dominika

    Szmitas – wielkie dzięki :) Miałeś rację, już wszystko śmiga. Jeżeli będę miała w przyszłości problemy z moim ubuntu napewno się do Ciebie zwrócę ;) Pozdrawiam

  • jarmot

    Świetny poradnik, jednak mam pytanie odnośnie kosza w tak zamontowanych partycjach. Przenoszenie plików do kosza mi nie działa, tylko usuwanie bezpowrotne. Bez modyfikacji fstab (domyślnie w Ubuntu 10.04) przenoszenie plików do kosza na partycjach NTFS było możliwe.

  • http://www.ubuntu-pomoc.org Szmitas
  • svantetic

    Mam Ubuntu 10.04, zrobiłam wszystko zgodnie z Twoją instrukcją, ale podczas uruchamiania system krzyczy, że nie może znaleźć utf8 i mam do wyboru albo to pominąć (co zrobiłam 2 razy, a partycja się zamontowała, miałam dostęp do plików, możliwość zapisywania itd.), albo zamontować ręcznie. Czy mogę po prostu usunąć to „utf8” z fstaba?

  • http://www.ubuntu-pomoc.org Szmitas

    Pokaż swój plik fstab. Nie bardzo wiem co informacja o kodowaniu robi w Twoim pliku :)

  • svantetic

    Oto mój fstab:

    # /etc/fstab: static file system information.
    #
    # Use ‚blkid -o value -s UUID’ to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    #
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/sda5 during installation
    UUID=bc622e91-22a5-464d-8120-3da57d1414e2 / ext4 errors=remount-ro 0 1
    # /home was on /dev/sda6 during installation
    UUID=9d5e6217-f7a2-4d08-84cc-b5122bbf13cc /home ext4 defaults 0 2
    # swap was on /dev/sda7 during installation
    UUID=0c5ec3df-c191-4f34-bc2e-30dc38abd21c none swap sw 0 0
    #dev/sda4
    UUID=473A2AAA47F5585F /media/sda4 ntfs
    defaults, utf8, unmask=007, gid=46 0 0

  • http://www.ubuntu-pomoc.org Szmitas

    Spróbuj usunąć to utf8 i zobacz czy coś się polepszy.

  • svantetic

    Teraz mu nie pasuje „unmask=007”, poza tym jest ok.

  • http://www.ubuntu-pomoc.org Szmitas

    To usuń, hehe ;)

  • svantetic

    Usunęłam „unmask=007”, później była awantura o „gid=46” i zrobiłam z nim to samo. A jak Ubuntu krzyczał o „0”, to usunęłam już oba -> przy uruchamianiu systemu jest „błąd montowania”, a kliknięcie „pomiń” skutkuje czarnym ekranem i kompletnym brakiem reakcji na bodźce zewnętrzne… Ratuj! Już nie raz korzystałam z porad z tej strony i działało bez bólu, na 9.04 montowałam tak jak tu i poszło, a teraz takie przeboje :(.

  • http://www.ubuntu-pomoc.org Szmitas

    A pozostawiasz przecinki? Może nie odpowiada systemowi ich brak?

    Usuń tylko utf8, ale zostaw wszelkie przecinki, a między dwoma wstaw spację – generalnie to co teraz Ci proponuję to jedynie kombinowanie. Podrzucę link jednemu z redaktorów i on spróbuje Ci pomóc za jakiś czas, pozdrawiam.

  • svantetic

    Teraz nie jestem w stanie tego zmienić mimo, iż próbowałam kilku kombinacji – nie mogę znaleźć sposobu, by zapisać fstab (za każdym razem mi wyświetla, że nie mam do tego uprawnień). Szukałam po różnych forach i bezskutecznie…
    Wielkie dzięki za dotychczasową pomoc i tak szybką reakcję :).

  • http://www.ubuntu-pomoc.org Szmitas

    Ulalala, to troszkę przekombinowaliśmy, hehe. Spróbuj przekopiować zawartość tego pliku w bezpieczne miejsce, usunąć go i stworzyć nowy :)

  • http://www.zakladobrobki.pl/ Jaack

    Hmm
    Ja na bierząco nie jestem, system nie startuje czy co teraz?

  • svantetic

    @ Szmitas: mógłbyś podpowiedzieć jak mam stworzyć nowy? Wybacz to pytanie, ale w życiu podobnych kombinacji nie robiłam i już się boję grzebać ;p.

    @ Jaack: były wszystkie aktualizacje na bieżąco robione. Teraz jest tak, że system się ładuje, pokazuje błąd podczas montowania i mam do wyboru pominąć (co skutkuje tym, że wchodzi czarny ekran i komputer się wiesza, nie reaguje na nic, prócz odcięcia prądu) albo montować ręcznie (po czym wchodzi maintenance shell, a ja robię wielkie oczy).

  • http://www.zakladobrobki.pl/ Jaack

    A sprawdzałaś czy CTRL+ALT+1 albo 2 (do 6) daje?
    Jak możesz montować ręcznie skoro fstab jest automatycznie wczytywany?

  • svantetic

    Jaack, na wszelkie kombinacje CTRL+ALT+1 itd. nie reaguje.
    Prawdopodobnie źle się wyraziłam i pobieżnie przetłumaczyłam opcję manual, wybacz :).

    Teraz jak odpaliłam kompa to wyskoczyło, „the disk mount for / is not ready or not installed”.

  • http://www.zakladobrobki.pl/ Jaack

    i to jest błąd który wywala grub?
    Bo teraz Ci głównej partycji nie chce zamontować ;/

  • svantetic

    Grub wyświetla się normalnie, wybieram system i jak mi się ładuje Ubuntu to pokazuje ten komunikat, daje wybór „skip” albo „manual” i po zabawie…

  • http://www.zakladobrobki.pl/ Jaack

    proponuję z livecd naprawić fstab

  • svantetic

    To było pierwsze, co próbowałam zrobić, ale system nie pozwala mi zapisać pliku – „read only”. Da się to jakoś wyminąć? Próbowałam googlować, ale nie udało mi się dokopać do informacji, jak to zrobić. Pomożesz? :)

  • http://www.ubuntu-pomoc.org Szmitas

    Bo robisz to źle ;) Najpierw musisz zamontować dysk, na którym masz zainstalowany system, następnie NA TYM DYSKU (a nie tak jak Ty to robisz – płycie) edytować plik fstab i go poskładać do kupy ;)

    Troszkę pogoogluj odnośnie montowania dysków z LiveCD i wszystko ogarniesz.

    Ewentualnie GG:7722046, pozdrawiam.

  • svantetic

    Zaczynam kapować ;).
    Wielkie dzięki za pomoc i cierpliwość, Panowie :).

  • http://www.zakladobrobki.pl/ Jaack

    Hehe, no, Szmitas, chyba będzie trzeba założyć czat z konsultantami xD

  • http://lukaszeq.pl Lukaszeq

    Działa! Masz u mnie za to piwko – nie muszę już za każdym razem przed odpaleniem banshee montować partycji NTFS na której mam muzykę :)

  • Szmitas

    Trzymam Cię za słowo! :)

  • Rafał

    Bardzo dobrze napisany tutorial. Dokładnie tego czego szukałem. Dziękuję!

  • sn82

    Partycje montują się prawidłowo, jednak przy otwieraniu dowolnego pliku tekstowego zamiast otworzyć się wyskakuje, że jest to plik wykonywalny i pyta się co zrobić. Pliki html zamiast otworzyć się w przeglądarce to tak samo są widziane jako wykonywalne. Jak to naprawić?

  • Barbapapa

    Nie wiem… ile lat ma już Linux czy samo Ubuntu.. nie można tego załatwić jednym ptaszkiem czy pytaniem podczas instalacji, chcesz automatycznie mountować dyski? Ptaszkuję przy tak. I problem z głowy. Nic się pod tym względem nie zmieniło o 1999 roku. :D

  • 1

    można zainstalować program MountMenager, lepsze wyjście dla użytkowników którzy nie chcą korzystać z terminala

  • Johan

    Z takim bzdetem trzeba się tak namęczyć… Linux nadal będzie do niczego w porównaniu z głupim windowsem, jeśli nie zmienią podejścia do użytkowników.

  • Maciej

    Nic z tego. w zaden sposób nie chce sie zamontowac. Dysk zajęty.

    oto komunikat jaki dostaję:

    „Mount is denied because the NTFS volume is already exclusively opened.
    The volume may be already mounted, or another software may use it which
    could be identified for example by the help of the ‚fuser’ command.”

  • Charles

    „tak jak pogrubiłem”, „tak jak zaznaczyłem” – nic nie pogrubiłeś i nic nie zaznaczyłeś!!

  • http://www.tuning.slask.pl gorg81

    Działa pięknie :) Dzięki.

  • Michał Konowalczyk

    Wspaniale.
    Ubuntu uruchamia się teraz jakby troszkę dłużej, ale nie muszę już za każdym razem montować trzech partycji z danymi. Ogólnie takie zadania nie są trudne, mogą jednak początkowo odstraszać złożonością. Palce mogą się nieco pocić przy wpisywaniu tych wszystkich cyferek.

    Linuks nie jest do niczego, zauważcie że system Windows nie widzi nawet partycji linuksowych, nie mówiąc już o korzystaniu z danych zapisanych na nich

  • Rocco31

    u mnie poszło jak w fstab wpisałem tak :
    #/dev/sda2 UUID=B2303BC3303B8CFB /media/windows
    ntfs3g defaults,utf8,umask=007,gid=46 0 0

  • Arek

    witam, niestety dostaje taki komunikat: The disk contains an unclean file system (0, 0).

    Metadata kept in Windows cache, refused to mount.

    Failed to mount ‚/dev/sda5’: Operacja niedozwolona

    The NTFS partition is in an unsafe state. Please resume and shutdown

    Windows fully (no hibernation or fast restarting), or mount the volume

    read-only with the ‚ro’ mount option

    • dte

      Nie odmontowałeś partycji z poziomu windowsa. Jak masz dualboot, to włącz windowsa, a następnie zamknij (nie hibernuj, nie resetuj ani nic). Polecam na przyszłość po prostu poczytać treść błędu + użyć google.

      • dte

        Aha i zapomniałem – należy wyłączyć w ustawieniach windowsa „szybkie uruchamianie”, bo windows żeby szybciej się uruchamiał nieodmontowuje swoich partycji i stąd te błędy.

  • Patryk

    Witam, a ja mam inne pytanie, wykonałem wszystko zgodnie z opisem. Dyski sie montuja przy restarcie ale mimo wszystko cos jest nie tak z accessem do nich. Mianowicie. Z poziomu samby nie moge do nich wejsc (oczywiscie jak sa dodane w configu) lub np PMS (plex) po restarcie, jak zamontuja sie dyski automatycznie nie odczytuje zamontowanych dyskow mimo ze jak sprawdze fizycznie w ubuntu to dyski sa zamontowane i jest do nich dostep. Musze je odmontowac i zamontowac jeszcze raz uzywajac komendy. Dopiero po takiej czynnosc wszystko wraca do normy. Moze ktos pomóc lub podpowiedziec jak to rozwiazać? wersja: Ubuntu Server 14.