ATI Catalyst – instalacja

Uwaga: Ten wpis został utworzony ponad rok temu. Informacje w nim zawarte mogą być nieaktualne!

Sterowniki własnościowe nie zawsze sprawują się poprawnie i konieczna jest instalacja ich zewnętrznych odpowiedników.
Sterowniki do kart graficznych ATI można zainstalować w bardzo łatwy sposób:

1. Odwiedź stronę producenta i pobierz odpowiedni sterownik klik.

2. Po pobraniu, przejdź w terminalu do katalogu, w którym pobrany jest plik i wydaj polecenie:

sudo sh ati-driver-installer-10-11-x86.x86_64.run

Wytłuszczony fragment to numer wersji – pamiętaj, aby go poprawnie uzupełnić.

3. Twoim oczom powinno ukazać się okno instalatora. Teraz już nie powinno być żadnego problemu.

4. Po zakończonej instalacji uruchom ponownie komputer.

Zdarza się, że po aktualizacji jądra, sterowniki ATI Catalyst nie działają poprawnie. Należy wtedy uruchomić system w bezpiecznym trybie graficznym i zainstalować sterownik ponownie.
Jeżeli powyższy artykuł nie rozwiązał lub rozwiązał częściowo Twój problem, dodaj swój komentarz opisujący, w którym miejscu napotkałeś trudności.
Mile widziane komentarze z uwagami lub informacjami o rozwiązaniu problemu.
  • ludwik94

    Niestety mi nie działa, ponowna instalacja nie pomogła, ja je teraz usunąć? Wyłączyła mi się akceleracja (przyśpieszenie) sprzętowe, docky mi to napisało, a na dole mam czarny pas.

  • ludwik94

    Dzięki za odpowiedź, jednak zdecydowałem się przeinstalować system ;) Zajęło mi to 1,2h a mojej pracy z 15minut, reszta to czekanie. Napisałem sobie skrypcik co mi instaluje wszystkie potrzebne mi programy. Kocham z to ubuntu!

  • marcinsud

    Wystarczy wstawić w komendę zamiast numeru wersji gwiazdkę i nie ma problemu

    sudo sh ati-driver-installer-*-x86.x86_64.run

  • AS_YA

    Tak, wszystko ładnie i pięknie – FaYnJe. Ale to ATI….
    A czy podjął by tutaj Ktoś temat jak na 10.04 zainstalować (też krok po kroku – wersja dla blądynki) TO:

    Instalowałam już sterowniki oferowane przez Ubuntu (wersje chyba 175 i 183) ale efekt jest baardzo mizerny :(

  • marcinsud

    AS_YA Ja sie podejmę dla nvidii na ubu 10.04 sprawa wygląda tak
    sudo apt-get install nvidia-current

    Wcześniej odinstaluj wszystkie inne stery jakie próbowałaś zainstalować. napisz tez jaką masz karte graficzną, bo jak jakąś starą to wtedy trzeba inne stery wybrać.

    • AS_YA

      Moja karta to nVidia GeForce 9600GT od Palit-a. Monitor 19″ 1440×900. Będę ‚wdzięczna’ :)
      Jestem początkującą użytkowniczką Ubuntu i mam jeszcze sporo innych problemów z tym systemem – no ale najważniejszy miałabym już z głowy…. Reszty się pewnie z czasem nauczę – jeszcze kilka-kilkanaście reinstalacji systemu i będzie prawie oki :)
      Poza tym porada taka byłaby również przydatna dla kolejnych pokoleń nowicjuszy…. :)

      • marcinsud

        no więc ta komenda którą podałem wyżej, powinno być ok. Po zainstalowaniu i restarcie
        sudo nvidia-settings

        tam ustawiasz sobie rozdzielczość i częstotliwość odświeżania ekranu, anstepnie dajesz save to x config file.

        • http://rocketdock.com/user/33759/addons/popular AS_YA

          Nie do końca zrozumiałam te komendy (chodzi mi o instalację sterowników z pliku .run) ale thanx za podpowiedź. Jutro postaram się ogarnąć ją dokładniej i napiszę czy coś pomogło. Dzisiaj jestem świeżo po reinstalacji całej Windy i dopiero jutro będę ponownie wgrywać Ubuntu – z tym zresztą mam także kłopot (opisałam to pobieżnie w komentarzu do artykułu tutaj)
          Nie wiem, ale wydaje mi się że Ubuntu nie lubi kobiet. Od ponad roku próbuję przesiąść się na Linuxa a tu zawsze coś nie tak….
          No cóż – nie od rzazu Rzym zbudowano.

          • marcinsud

            Nie trzeba instalować sterowników z pliku run. Ta sama wersja 260 ileś tam jest w repozytorium i działa dobrze nazywa się nvidia-current. Do tego po aktualizacji jądra moduł sterownika będzie się sam budował i działał na nowym jądrze, przy sterach z pliku run nie zawsze jest tak kolorowo.

  • http://rocketdock.com/user/33759 AS_YA

    marcinsud >
    A więc tak:
    Zainstalowałam bezproblemowo ‚czyste’ 10.04 i nie wgrywałam żadnych sterowników nVidii – w moim przypadku nie są już potrzebne. Bynajmniej teraz – na razie – dopóki poznaję Linuxa i w wyniku moich błędów dość często wgrywam go od nowa….
    Dlaczego niepotrzebne….?
    A dlatego że przed instalacją Ubuntu fizycznie odmontowałam kartę grafiki z komputera a system pracuje teraz na karcie zintegrowanej: ATI-X-coś-tam.
    Otóż (NAJPRAWDOPODOBNIEJ) okazało się że do wymontowanej karty graficznej GeForce 9600GT mam najzwyczajniej zbyt słaby, a może i już nawet chyba lekko uszkodzony zasilacz (350W).
    Ale to już inna sprawa….
    Jeśli chodzi o ‚nvidia-current’ w Synapticu to tak – są (jako niezainstalowane), ale są opatrzone symbolem 195-coś-tam a nie 260-coś-tam.
    No nic. Jeśli chodzi o nVidię to na razie poddaję partię i idę sobie pozmywać naczynia.
    Ale dzięki za sugestię (‚nvidia-current’ 195….) – wyprubuję tę opcję po wymianie zasilacza.
    THX i Pozdrawiam.

    • marcinsud

      rzeczywiście w wersji 10.04 nie ma wersji 260, jest dopiero w wersji 10.10. Wersja 195 jednak obsługuje wszystkie geforcy od serii 6 do 9 więc powinno trybić.

  • siema

    Siemanko. Jestem użytkownikiem LU 11.04, mam go od wczoraj. A więc przechodzę do sedna sprawy…. nie chce uruchomić mi sie Unity, ponieważ nie mam zainstalowanych sterów. Mam kartę Ati Radeon x1050 (proszę sie nie śmiać :D) i nie radze sobie ….. próbowałem zainstalować powyższe sterowniki, ale nic to nie dało :/
    Ściągałem z neta ze strony ati, gdzie można pobierać stery, ale po wpisaniu modelu karty i systemu operacyjnego wyskakuje mi jakis sterownik…. pobieram go, ale nie chce sie zainstalować.
    Aha na oryginalnej plytce ze strami na winde mam instalator Driver ver. 12-063 (8.33)
    Nie wiem co zrobić, czy możecie mi dać link do odpowiednich do tej karty sterowników, które będę mógł zainstalować?!
    pozdro Mati :)

  • http://www.ubuntu-pomoc.org Szmitas

    ale nie chce sie zainstalować

    Co to znaczy? Szczegóły nam są potrzebne, abyśmy mogli pomóc.

  • siema

    instalacja sterownika pobranego prze zemnie: wyskakuje bład nie chce się wyłączyć
    -treść błędu: „Error: ./default_policy.sh does not support version
    default:v2:i686:lib::none:2.6.38-10-generic; make sure that the version is being
    correctly set by –iscurrentdistro”
    ——————————————————
    instalacja sterowników pobranych z tej strony: uruchamia się, ale dalej nie wiem co wybierać, żeby było dobrze
    1. ekran instalatora: http://img823.imageshack.us/img823/8550/zrzutekranu1s.png, którą z opcji wybrać?!
    2. po wybraniu opcji (2)!: http://img824.imageshack.us/img824/2149/zrzutekranu2k.png, co z tego tym razem wybrać?!
    ———————————————————
    Może to głupie pytanie, ale pierwszy raz korzystam z pingwina, nie jestem obcykany w tych sprawach :/

    • http://www.ubuntu-pomoc.org Szmitas

      Wybierz pierwszą opcję.

  • Pingback: Ubuntu - pomoc | Usunięcie ATI Catalyst()

  • amduser

    Możecie pobrać najnowsze Catalyst 12.8? Wyskakuje ciągle 404 – Not Found!

  • czapla

    Witam,
    Mam problem z radeonem hd 4850, nie moge zainstalowac sterowników plus saucy salamander nie rozpoznaje karty. Chcę zaznaczyć że to moja pierwsza stycznośc z linuksem i prosiłbym o łopatologiczne wytłumaczenie co i jak. Udało mi się uruchomić sterowniki wybieram opcję pierwszą czyli install driver 8.97.100.7 on X.org 6.9 or later 64-bit po czym wyskakuje że jest brak jednego bądź więcej narzędzi i że mam najpierw je zainstalować żeby przed instalacją fglrx.